Last Comment Bug 624798 - nsBidiPresUtils should not keep state as member variables
: nsBidiPresUtils should not keep state as member variables
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Other Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Simon Montagu :smontagu
:
Mentors:
Depends on: 651229
Blocks: 566066
  Show dependency treegraph
 
Reported: 2011-01-11 11:22 PST by :Ehsan Akhgari
Modified: 2011-07-13 00:07 PDT (History)
5 users (show)
smontagu: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (111.96 KB, patch)
2011-03-16 07:53 PDT, Simon Montagu :smontagu
no flags Details | Diff | Splinter Review
Patch v.2. updated to tip and to comments (110.86 KB, patch)
2011-03-30 13:41 PDT, Simon Montagu :smontagu
roc: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2011-01-11 11:22:46 PST
See bug 624722 comment 4.
Comment 1 Simon Montagu :smontagu 2011-03-16 07:53:21 PDT
Created attachment 519654 [details] [diff] [review]
Patch

This applies on top of the patches in bug 263359
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-03-16 14:28:30 PDT
Comment on attachment 519654 [details] [diff] [review]
Patch

This review is a bit rubber-stamp-y but it looks good to me.

+  nsBidi*             mBidiEngine;

nsAutoPtr

Some of the nsTArrays should probably be nsAutoTArray.
Comment 3 Simon Montagu :smontagu 2011-03-30 13:41:53 PDT
Created attachment 523097 [details] [diff] [review]
Patch v.2. updated to tip and to comments
Comment 4 Simon Montagu :smontagu 2011-04-13 02:28:24 PDT
http://hg.mozilla.org/mozilla-central/rev/ad5009233ae9
Comment 5 Simon Montagu :smontagu 2011-04-27 01:54:10 PDT
Backed out in http://hg.mozilla.org/mozilla-central/rev/fa0295a97f1b because of bug 650189
Comment 6 Simon Montagu :smontagu 2011-07-13 00:07:23 PDT
http://hg.mozilla.org/mozilla-central/rev/b529ffc1012b

Note You need to log in before you can comment on or make changes to this bug.