If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

on lexis.com search pages, right/middle clicks treated as left mouse click (site uses links with onclick)

RESOLVED WORKSFORME

Status

SeaMonkey
General
P3
normal
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: James Miller, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Lexis is one of the two major legal research companies in the U.S.--Westlaw
being the other.

Searches return a list of links and up until I would guess the 11/26 nightlies
or so I could right click or middle-click on the links and open them in a new
window, etc.

However, the recent builds now illicit a different behavior.  Now any mouse
input on the links initiates a left-mouse click and selects the link.

It may be hard to reproduce this in house given that Lexis (and Westlaw) are
expensive subscription services.  I have an account by virtue of being a law
student.

Please let me know if I can help in debugging this...

Comment 1

17 years ago
I have a Lexis-Nexis account, will dig up the password for it tomorrow, but in 
the meantime you could help us out by attaching a small testcase of the code 
causing trouble. Thanks.

Comment 2

17 years ago
Can you (James) or Blake confirm this behaviour in a more recent build? Thanks.
(Reporter)

Comment 3

17 years ago
I have the 2000122808 build (linux i386 nihgtly build) and unfortunately both
middle and right clicks exhibit the same behavior.  Total pain, when you've got
a list of 100's of cites and you want to middle-click and leave the search
result frame alone.

Here's what the aref's look like... calls the this.href into the _parent frame
but I don't see this breaking elsewhere?


<a
HREF="/research/retrieve/frames?_m=3893937800d843b5cac9e2d7a094e108&docnum=1&_fmtstr=FULL&_startdoc=1&_startchk=1&wchp=dGLStS-lSlWV&_md5=077e0ebcc2749a64592200ff83e4190d"
onClick="setTaggedDocsState(this.href,0,'parent'); return false;" target="_parent">

Comment 4

17 years ago
Yuck.

Can someone tell me what happens in this testcase:

<a href="javascript:alert('left click');" onclick="alert('FAILED; I got a 
click');">Testcase</a>
<a href="javascript:alert('left click');" onclick="alert('FAILED; I got a 
click');" target="_top">Testcase2</a>
(Reporter)

Comment 5

17 years ago
Same behavior for both.

Namely right click generates the failed dialog but not the left-click dialog and
middle click generates failed dialog in original window followed by left click
dialog in new instantiated window.

<a href="javascript:alert('left click');" onclick="alert('FAILED; I got a
click');">Testcase</a>

left-click == failed dialog + left click dialog
right-click == failed dialog
middle-click == failed dialog in original window + new window created then left
click dialog in the new window

 <a href="javascript:alert('left click');" onclick="alert('FAILED; I got a
click');" target="_top">Testcase2</a>

left-click == failed dialog + left click dialog
right-click == failed dialog
middle-click == failed dialog in original window + new window created then left
click dialog in the new window



Comment 6

17 years ago
onclick is supposed to fire on any button click.  what's the problem?

Comment 7

17 years ago
ok, i'm inches away from moving this to wontfix/invalid/evang.

Reporter: please file an RFE to change our handling of web:onclick to 
oncommand.

Blake: yeah.

fwiw, my testcase is relatively useless, since i'd need to find out which 
button was clicked and then return true or false to avoid or allow the href 
handler.  However, it does completley paint the picture, so i'm fine w/ it.

Personally i find the w3's mouse centric implementations troubling.
(Reporter)

Comment 8

17 years ago
Ok, my bad then.  I was able to right or middle click links from lexis before
but not now.  Perhaps Lexis wasn't using an onClick() method before?  I'll see
if I can find some old search returns saved somewhere.

There have been other quirks at both lexis and westlaw btw that have all gone
away.  As I recal (I can confirm if it's useful) the M18 builds were having
problems with posting the user authentication pages for lexis and westlaw frames
weren't rendering correctly.  That all went away and started working in
subsequent nightly builds.

Outside of this recent quirk I don't observe any problems at Westlaw or Lexis!

onClick="setTaggedDocsState(this.href,0,'parent'); return false;" target="_parent">

Comment 9

17 years ago
Mark this wfm?

Updated

17 years ago
Summary: right/middle clicks on links in search pages from http://www.lexis.com pass a left mouse click instead... → on lexis.com search pages, right/middle clicks treated as left mouse click (site uses links with onclick)

Comment 10

17 years ago
Marking WORKSFORME since no one else seems to be doing it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.