app.update.lastUpdateTime.* preference can get accidentally set to a time in the future which will prevent timer notifications

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

If a system's clock is set to a date / time in the future and the update timer manager notifies a consumer the consumer's next notification time will be based on the system's date / time. So, if the user then fixes their systems clock the next notification won't happen until after the date / time the system was set to in the future.

The update timer manager has always been this way so this is not a regression though I think this should be considered for blocking.
blocking2.0: --- → ?
Sucks but as it's not a regression and it probably only affects a small subset of users we shouldn't block the release on this
blocking2.0: ? → -
Duplicate of this bug: 689059
This was fixed in other bugs which I don't have the number handy for so resolving wfm
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.