StartupWMClass Tags Messed Up

RESOLVED INVALID

Status

Thunderbird
OS Integration
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: roastedtiresx@gmail.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Ubuntu/10.10 Chromium/8.0.552.224 Chrome/8.0.552.224 Safari/534.10
Build Identifier: 3.1.8pre

The PPA/added repo version of Thunderbird, code named Shredder, is not properly set up with the .desktop files that certain applications in Linux use. As a result, it makes it a major headache to use applications like Thunderbird. I spoke to several developers with fixes for this, but this problem stems from Mozilla. The stable releases that come pre-packaged with distributions such as Ubuntu work absolutely fine, but the PPA/repo versions that update frequently do not. Can this be fixed so things are more seamless for everybody?

Reproducible: Always

Actual Results:  
Happens every time unless I go back in and edit certain config files.
(Reporter)

Updated

8 years ago
Summary: StartWMClass Tags Messed Up → StartupWMClass Tags Messed Up
I believe this is INVALID for bmo, but I'm not sure. Crhis can you confirm that the issue is Ubuntu packaging only ?
Component: General → OS Integration
QA Contact: general → os-integration

Comment 2

8 years ago
Yes, this is because we hard-code StartupWMClass in the desktop file to "Thunderbird". For the Firefox packaging, we automatically populate it with the correct name at build time, based on the branding being built. I need to update the Thunderbird packaging to do the same thing as well so that the nightlies work properly.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.