Closed Bug 624962 Opened 9 years ago Closed 9 years ago

Permanent browser_tab_dragdrop.js | tab0 uri - Got http://example.org/browser/browser/base/content/test/dummy_page.html#tabmatch18, expected

Categories

(Firefox :: Tabbed Browser, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b10

People

(Reporter: philor, Assigned: Unfocused)

References

Details

(Keywords: intermittent-failure, Whiteboard: [fixed by bug 558321 backout])

Attachments

(1 obsolete file)

(Expected a little more room for a summary, I did)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294802430.1294805272.29872.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2011/01/11 19:20:30
s: talos-r3-leopard-041

TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_tab_dragdrop.js | tab0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_tab_dragdrop.js | tab0 uri - Got http://example.org/browser/browser/base/content/test/dummy_page.html#tabmatch18, expected about:blank
Attached patch Possible fix (obsolete) — Splinter Review
I gotta run out, but I think this may fix it, assuming it is indeed caused by leftover tabs from browser_tabMatchesInAwesomebar.js
Summary: Intermittent browser_tab_dragdrop.js | tab0 uri - Got http://example.org/browser/browser/base/content/test/dummy_page.html#tabmatch18, expected → Permanent browser_tab_dragdrop.js | tab0 uri - Got http://example.org/browser/browser/base/content/test/dummy_page.html#tabmatch18, expected
Component: Tabbed Browser → General
QA Contact: tabbed.browser → general
Started in this range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b6f7632f63b7&tochange=7a3469118cf3

My money is on the patch for bug 558321
Assignee: nobody → bmcbride
Whiteboard: [orange] → [orange][fixed by bug 558321 backout]
Attachment #503069 - Attachment is obsolete: true
Fixed by backout, and bug 558321 was re-landed with a fixed test.
Status: NEW → RESOLVED
Closed: 9 years ago
Component: General → Tabbed Browser
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
Whiteboard: [orange][fixed by bug 558321 backout] → [fixed by bug 558321 backout]
You need to log in before you can comment on or make changes to this bug.