Closed Bug 624965 Opened 9 years ago Closed 7 years ago

Intermittent make check timeout in editor/txmgr/tests/TestTXMgr.cpp's "Aggregate Transaction Stress Test"

Categories

(Core :: Editor, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Assigned: ehsan)

References

Details

(Keywords: intermittent-failure, Whiteboard: [post-2.0])

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294782688.1294800327.4520.gz
WINNT 5.2 mozilla-central leak test build on 2011/01/11 13:51:28
s: win32-slave20

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294783603.1294793578.2021.gz
Linux mozilla-central leak test build on 2011/01/11 14:06:43
s: moz2-linux-slave08

-----------------------------------------------------
- Aggregate Batch Transaction Stress Test:
-----------------------------------------------------
Stress test of 500 iterations (may take a while) ... 
command timed out: 300 seconds without output, killing pid 29983
The smell of infra is strong here: TraceMonkey and mozilla-central's parent is probably close to a week old, but

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294785227.1294795407.12141.gz
Linux tracemonkey leak test build on 2011/01/11 14:33:47 
s: moz2-linux-slave09

Stress test of 500 iterations (may take a while) ... 
command timed out: 300 seconds without output, killing pid 26494

is rather close to the same time.
We might not actually need this test at all.  Will investigate post 2.0.
Assignee: nobody → ehsan
Whiteboard: [orange] → [orange][post-2.0]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298575508.1298589028.29198.gz
Linux mozilla-central leak test build on 2011/02/24 11:25:08
s: moz2-linux-slave13
This has only happened once since the original occurrence.  I'm going to call it WFM unless proven wrong.
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange][post-2.0] → [post-2.0]
You need to log in before you can comment on or make changes to this bug.