Firefox does not implement the SVG onresize event for outermost svg tag

RESOLVED DUPLICATE of bug 509795

Status

()

--
major
RESOLVED DUPLICATE of bug 509795
8 years ago
8 years ago

People

(Reporter: shropshire, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

When I resize the browser window, Firefox should call my onresize event handler on the outermost svg tag but it does not.  Other browers like Chrome, Opera, and IE8 w/Adobe SVG work fine.

Reproducible: Always

Steps to Reproduce:
Open sample SVG page.  Then resize the browser window.  Nothing happens.  Do same in Chrome/Opera to see correct response.
Actual Results:  
Nothing happens.

Expected Results:  
Should see a javascript alert message box.
(Reporter)

Comment 1

8 years ago
Created attachment 503119 [details]
This SVG sample demos the issue

SVG sample that shows bug.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
This bug is also in Firefox 4 R 8 beta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509795
You need to log in before you can comment on or make changes to this bug.