Closed Bug 625015 Opened 9 years ago Closed 6 years ago

update confusing error message "Could not compile basic X program"

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla29

People

(Reporter: u367160, Assigned: sylvestre)

Details

(Whiteboard: [qa-])

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.04 (lucid) Firefox/3.6.13 GTB7.1
Build Identifier: 

when building mozilla-central on linux, if environment miss the xt-dev package configure process will give a confusing error message "Could not compile basic X program" and do not tell which library should be installed.

I update this error message to "Could not compile basic X program. xt-dev package not installed."

Reproducible: Always
Attachment #503137 - Flags: review?(jhford)
Component: General → Build Config
QA Contact: general → build-config
The package isn't called "xt-dev" on all Linux distributions, much less on the other operating systems where this code runs.  So I don't see how this message is much better than what we had before, unless you happen to be on Ubuntu Linux in particular.

(For example, it's called "xorg-x11-libXt-devel" on Fedora, "libxt6-devel" on Mandriva, etc.)

If the message actually said which _library_ we're missing, that would work for me (then the user can use their package manager to get the right package for that library).
is it ok if I add corresponding package name for Fedora and SuSE as well? because I saw there is a such error message just below that line:
Can't find header GL/glx.h for WebGL (install mesa-common-dev (Ubuntu), mesa-libGL-devel (Fedora), or Mesa (SuSE))
patch updated based on the comment, thanks
Attachment #503137 - Attachment is obsolete: true
Attachment #503426 - Flags: review?(bzbarsky)
Attachment #503137 - Flags: review?(jhford)
I'm not a module peer for this code, so I can't review that patch.  But yes, listing the various package names would be a lot better.

That said, the Fedora package name is certainly wrong; there is no such package on Fedora.  Where did you get it?  Where did you get the SuSE package name?

Which files is this test actually checking for, by the way?  Your patch doesn't have enough context to tell....
Comment on attachment 503426 [details] [diff] [review]
proposed patch to make error message more clear

I've got package names from here:
https://developer.mozilla.org/En/Developer_Guide/Build_Instructions/Linux_Prerequisites

this test checking for files, it looks also checking some c headers as well, but I think X11 headers is more important here.
9213     AC_TRY_COMPILE([
9214         #include <stdio.h>
9215         #include <stdlib.h>
9216         #include <X11/Xlib.h>
9217         #include <X11/Intrinsic.h>
9218     ],

http://mxr.mozilla.org/mozilla-central/source/configure.in#9226

removed bzbarsky from reviewer
Attachment #503426 - Flags: review?(bzbarsky)
> I've got package names from here:

The names in your patch don't match the ones on that page.  At least the Fedora one does not.
ooops, sorry my mistake. Thanks for pointing it out
patch updated
Attachment #503426 - Attachment is obsolete: true
Bumped into this message when compiling xulrunner 13.0

For the record, the "xt-dev" package for ubuntu (tried on 12.04) is "ibxt-dev"
Sorry, typo. "libxt-dev"
Here is the refreshed patches of Aikeremu Tiemuer.
I am taking the bug since there is no activity on it for a while
Assignee: nobody → sylvestre
Attachment #503535 - Attachment is obsolete: true
Attachment #8348600 - Flags: review?(mh+mozilla)
Attachment #8348600 - Flags: review?(mh+mozilla) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/30c5b0398c6f
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Whiteboard: [qa-]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.