Closed Bug 625020 Opened 11 years ago Closed 11 years ago

Checksetup.pl does not check for List/MoreUtils.pm

Categories

(Bugzilla :: Installation & Upgrading, defect)

x86_64
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 611129

People

(Reporter: guzman, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.19) Gecko/2010040123 Ubuntu/8.10 (intrepid) Firefox/3.0.19
Build Identifier: 3.6.3

Heya!

Just installed 3.6.3 from scratch, after simple config & submit a few bugs, when click on My Bugs it fails because perl can't find List/MoreUtils.pm.

After that perl module was installed my bugs was working again.

Suppose fix would be to add this module to checksetup.pl as it usage becomes part of basic functionality.



Reproducible: Always

Steps to Reproduce:
1. Install 3.6.3 on Debian lenny following checksetup.pl
2. Satisfy perl modules using packages when possible and leave MIME::* and Template::* to be installed through Bugzilla perl module install script.
3. Configure installation (products), create a few bugs, click on My Bugs.

Actual Results:  
Software error:

Can't locate List/MoreUtils.pm in @INC (@INC contains: . lib/x86_64-linux-gnu-thread-multi lib /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at Bugzilla/Search/Quicksearch.pm line 34.
BEGIN failed--compilation aborted at Bugzilla/Search/Quicksearch.pm line 34.
Compilation failed in require at /var/www/bugzilla/buglist.cgi line 42.
BEGIN failed--compilation aborted at /var/www/bugzilla/buglist.cgi line 42.


Expected Results:  
Buglist.

Maybe has to do with the way I've installed perl modules (some through APT, some through Bugzilla), but however users install those modules, checksetup.pl should check for all modules that are required for basic functionalities.
Already fixed in 3.6.4.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611129
You need to log in before you can comment on or make changes to this bug.