Closed Bug 625058 Opened 14 years ago Closed 12 years ago

Enable crashtest-ipc for Mac machines

Categories

(Release Engineering :: General, defect, P5)

All
macOS
defect

Tracking

(fennec-)

RESOLVED FIXED
Tracking Status
fennec - ---

People

(Reporter: cjones, Unassigned)

References

Details

(Whiteboard: [unittest][new suite])

See also bug 623613 and bug 624851.

Tentatively blocking on bug 622229 so that we have the option of running these tests on 10.6 slaves.  The multi-process gfx code *must* USE_WIDGET_LAYERS or else most tests will fail.  If need be, we could limit the tests to 10.5 machines for now to unblock.

We should be fine to run reftest-ipc with or without GL compositing on mac; it should work equally well for both.  Using whatever happens to be default on the machine works for me.
I'm seeing firefox-bin/plugin-container just sit apparently idle for long periods of time during startup.  I suspect that message notifications are being dropped in plugin-container.  The reftest harness is very unforgiving of these bugs because it relies on specific sequences of small numbers of messages; there's not periodic spam to bail out p-c.  Unfortunately, I can't run the IPDL unit tests because ipdlunittest-bin is failing to start up in a scary-looking way.  I'll see if there are upstream changes we can pull.
Oops, that was supposed to be posted in bug 625060.
The reftests are mainly failing for niggly pixel differences due to the duct-tape-and-rubber-band rendering setup.  We're never going to ship out-of-process content with this code, so I don't think it's worth investing time sorting out these failures.

I *do* think it's worth running the crashtests so that we know of big problems caused by platform changes.
Summary: Enable reftests+crashtests for out-of-process content on Mac machines → Enable crashtests for out-of-process content on Mac machines
I think this should block because it's going to be our only automated way to catch broken mac nightlies of fennec, which extension developers are expected to use.
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0-
Priority: -- → P3
Whiteboard: [unittest][new suite]
In my last try push (263d877928ac),
 - the opt tests timed out in two tests,

TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/style/crashtests/192408-1.html
TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/svg/crashtests/612662-1.svg

 - the debug tests were timing out and also failing the same assertion checks as in bug 623613 comment 32

These aren't ready to enable yet.
Hi cjones according to your comment:
Would you be OK to close this bug until it is ready for us?
Then file another bug or REOPEN when ready.
Sounds good?
Priority: P3 → P5
That's fine.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INCOMPLETE
This is an old bug, but some of the analysis may still be valid, so reopening instead of filing anew.
Blocks: 845161
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Summary: Enable crashtests for out-of-process content on Mac machines → Enable crashtest-ipc for Mac machines
Fixed in bug 624851.
Status: REOPENED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.