Closed Bug 625214 Opened 9 years ago Closed 9 years ago

Add a results pane for test suites

Categories

(Mozilla QA Graveyard :: MozTrap, enhancement, P1)

enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 650979

People

(Reporter: aakashd, Unassigned)

References

Details

Attachments

(1 file)

The TCM will need a results pane for test run results collected from logged
in users. In this pane, the following will be needed:

* A table of results entries with values shown for name, failed, invalid, tester, bugs
* Default list of 20 results shown
* A combobox to set the number of results per page going from 10,20,50 and 100.
When selected, the page should AJAX-ily update the listings area rather than
require a new page load.
* A checkbox per row entry when a logged in user is an admin
* Pagination that allows users to go to a certain page and to the beginning and
end of the set of results AJAX-ily.
Depends on: 625188
Attached image mockup
This does not correlate to results panel correctly as the purpose is to view results of specific versions of testcases and test runs. It would not be advantageous to see a running count of tests failed/passed outside the bounds of versions within each testcase in the testsuite.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
It's possible that this bug should be reopened, given the comments on https://bugzilla.mozilla.org/show_bug.cgi?id=625213 re the importance of reporting by test suite.

I think it would need to be phrased a bit differently, though, and reached only via drilldown from a test run. It isn't meaningful to report results on a test suite alone, but a test suite as included in a particular test run.
Target Milestone: 0.2 → 0.3
Resolution: INVALID → DUPLICATE
Duplicate of bug: 650979
Bumping to verified duplicate
Status: RESOLVED → VERIFIED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.