Closed Bug 625224 Opened 9 years ago Closed 9 years ago

Connect row can be hidden while "Enable Sync" toggle is true

Categories

(Firefox for Android Graveyard :: General, defect, minor)

defect
Not set
minor

Tracking

(fennec2.0b4+)

VERIFIED FIXED
Tracking Status
fennec 2.0b4+ ---

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
(In reply to bug 619795 comment 11)
> Oh, and after killing the app and restarting, I saw sync enabled but the
> connect button missing (see attached screenshot). The button re-appears after
> you switch sync off and then on again.

From inspecting the code, this might happen if browser.sync.enabled is changed from false to true by something other than the user pressing the toggle switch.  Then the #setting-base pref observer will flip the toggle, but it won't run the oncommand handler to show the preference row.

I can't reproduce whatever caused this, but changing this to use oninputchanged instead of oncommand will prevent this from ever getting out of step like that.
Attachment #503336 - Flags: review?(mark.finkle)
Attachment #503336 - Flags: review?(mark.finkle) → review+
tracking-fennec: --- → 2.0b4+
http://hg.mozilla.org/mobile-browser/rev/3fbd997e8010
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified as fixed on:
Mozilla/5.0(Maemo; Linux armv7l; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre Fennec/4.0b4pre
and 
Mozilla/5.0(Android; Linux armv7l; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre Fennec/4.0b4pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.