psm.exe crashes on this site

VERIFIED FIXED

Status

()

P3
critical
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: mozbug, Assigned: ddrinan0264)

Tracking

1.0 Branch
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
2000121008 trunk WinNT4 SP6a

Go to URL
psm.exe causes an access violation.

I can't get talkback to show up no talkback id.
I'm attaching DrWatson log.
(Reporter)

Comment 1

19 years ago
Posted file DrWatson log

Comment 2

19 years ago
Same on site 'bic.wau.nl' (access to Wageningen University LAN from outside).
Probably on more secure sites? It could be a blocker for opening any secured site.
Using same build but win98. Build of 1207 worked OK.

Comment 3

19 years ago
Sorry, forgot to cc myself...
(Reporter)

Comment 4

19 years ago
Same thing here https://www.md.ucl.ac.be/intranet/

And after psm.exe crashed, Mozilla's CPU usage grows to nearly 100%.
(Reporter)

Comment 5

19 years ago
And another one, http://www.hotmail.com/

As Vincent remarke it, build of 12/07 doesn't crash. The problem arose since psm
is included in the nighly build (12/08 or 12/09, I don't remember)

Comment 6

19 years ago
I am confirming and nominating as blocker of the day. This happens since PSM has 
been embedded in the Mozilla builds. Someone from the PSM embedding should view 
bonsai to see which checkin caused this.
Fabian.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

19 years ago
Note: If you copy the psm.exe file from the commercial 12-11 Netscape 6 WinNT 
build over the psm.exe in the nightly Mozilla build, SSL works.
(Assignee)

Comment 8

19 years ago
I cannot reproduce this with my debug builds. I'm spinning off an optimized 
build right now to see if the problem shows up then.
(Assignee)

Comment 9

19 years ago
I cannot reproduce this with my optimized builds either. I will update my tree 
(it's a few days old) and do a clobber build.
(Assignee)

Comment 10

19 years ago
Adding Javi to the cc-list.

I've updated my tree and did a clean optimize build and I still cannot reproduce 
this crash. Javier is going to do a clean pull and build of Mozilla (with 
BUILD_PSM set to 1) on his machine to see if he can reproduce this crash.

Comment 11

19 years ago
psm.exe crashes when trying to enter https://www.eyp.ee/

My Mozilla build is 2000121104
My OS is Windows NT 4.0 Workstation with SP6 installed

Following is pasted from MS Sysinfo:
Operating System:		Windows NT
Windows version:		4.0
Processor:
		Pentium
Total physical memory:		261492 KB
Available physical memory:	119572 KB*
USER memory available:		90%
GDI memory available:		90%
Swap file size:			516720 KB
Swap file usage:		28%
Swap file setting:		Dynamic
Available space on drive C:	3948423 KB
Windows directory:		C:\WINNT
TEMP directory:			C:\TEMP

Hope this information helps :)
I crashed at https://rechnungonline.t-d1.de/inline/login/login.jsp

Build 2000120920 / Win2k SP1 / Athlon900 / 256MB RAM

Comment 13

19 years ago
has anybody been able to find a SSL site that psm works with?  I'm going to
agree with Fabian and nominate for blocker.

oh and add https://cubmail.cc.columbia.edu to the list

Comment 14

19 years ago
I agree with Fabian and Jason. Nominating for blocker.

Comment 15

19 years ago
If psm doesn't work, you cannot access ANY site. Can you people start the
security manager from the tools menu? I cannot. If it will not start, there is
no point in even trying to do secure surfing.

Comment 16

19 years ago
Just tried. Starting PSM from tools menu gives the same error message. So indeed
you should not be able to acces any secured site.

Comment 17

19 years ago
I just visited that site with a fresh pull and optimized build from last night
from around 7 pm.  Doesn't crash.  I'm even doing SSL/IMAP.

Is there another version of PSM installed on your machine?  Perhaps that was is
conflicting when you try to run your nightly build.

Comment 18

19 years ago
just grabbed the latest win32 nightly (2000121204) and I still get horkage when
trying to go to https://cubmail.cc.columbia.edu.

I did a clean install. blew away profile, install dir, and mozver/mozregistry.

Comment 19

19 years ago
I'll add sourceforge to the list of affected sites. That makes it pretty
critical in my book!

http://sourceforge.net/

Comment 20

19 years ago
If this bug is affecting your work, then re-vert to the older version of PSM on
the iPlanet web site.  That one should still work with a nightly Mozilla build.

Comment 21

19 years ago
are there any steps needed to uninstall the current embedded PSM before we use
the iPlanet one?

Comment 22

19 years ago
What works is to install PSM from iPlanet, then copy the psm.exe file from the 
new install to the same folder that contains mozilla.exe

Comment 23

19 years ago
Re-naming bin/psm.exe to something else should do it.  Alternatively, you could
delete the file bin/psm.exe and delete the contents of the directory bin/psmdata
as well.

The version on iPlanet will install to the directory bin/psm, so you need to
move the other one out of the way so mozilla doesn't try to run that one instead
of the one installed from iPlanet.

Comment 24

19 years ago
*** Bug 62692 has been marked as a duplicate of this bug. ***
*** Bug 62780 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 26

19 years ago
I saw in Mozillazine that the Mac nighlies had a working version of psm, so I
tried once again with a win32 build (2000121620 trunk).
Now https://www.gbanking.be/ and other secure sites don't crash psm.exe (on my
win98 machine)

Comment 27

19 years ago
I just downloaded and installed 2000121620 on a new win2k machine. (I did have
NS 4.76 and 6 installed).

Well, PSM runs but not right. If I open a https page (https://bant.ms.ornl.gov)
and then open PSM.exe, and click on the certificate tab (the page information
stays blank), the certificate management list is displayed in the main Web page
and NOT in the PSM window!

Comment 28

19 years ago
Hmmm... I just tried to go to https://bic.wau.nl with win32 talkback build
2000121720, but for me psm still crashes.
(Reporter)

Comment 29

19 years ago
No crash for me on https://bic.wau.nl (2000121804 trunk win98 and 2000121720
trunk NT4 SP6a)

Comment 30

19 years ago
Deleted mozilla/bin entirely, unzipped latest nightly 2000121820 (win32), and
PSM still crashes... Please don't tell me I have to clean the registry and
profile's again...
(Reporter)

Comment 31

19 years ago
It's worth a try.
I ran several times against bugs that resolved by deleting the registry and
profiles.

Comment 32

19 years ago
Then we should change the name of this bug to "Deleting registry and profiles 
needed for successful install of PSM."  This is not a viable option for people 
needing to upgrade. It destroys your mail and bookmarks and address books.

Comment 33

19 years ago
Well, go ahead and change that name...
I gave it a try, and it works. Deleting the registry.dat in mozilla/bin seems to
be the only way to get PSM working again. Though it's kind of a job to
reconstruct as much as possible of your prefs and mail and bookmarks indeed.
It's just that i've done it several times before, so I know which files to copy
before deleting the profile.
(Reporter)

Comment 34

19 years ago
I'm not for the change of name.
psm stopped crashing since 2000/12/17 and I didn't have to destroy my profiles.

Comment 35

19 years ago
Ok, actually I agree to Gilles. The actual bug has been fixed, it is just the
fact that mozilla does some strange things with it's own registry file that
causes the trouble. Or with another file in the profiles folder.
I mean, this is not the way a program should manage it's registry. It should be
build-independent, which it is also meant to be in Moz' case I believe, as it is
not redistributed with every build. And otherwise, the new build should
'convert' the old registry (or profile files) somehow to fit the new build.
Anyway, it gets a bit off-topic now. Maybe some test-users are in for a special
moz regedit and profile edit util :-)
To be entirely clear: I do agree on the fix of this bug. PSM does not crash anymore.

Comment 36

19 years ago
Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 37

19 years ago
Verified fixed with the 12/21 WinNT commercial trunk build.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: PSM → Security: PSM
Product: PSM → Core

Updated

11 years ago
Version: psm1.5 → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.