put *.xpi files in /pub/mozilla/nightly/latest

RESOLVED WONTFIX

Status

mozilla.org Graveyard
Server Operations
P3
normal
RESOLVED WONTFIX
18 years ago
3 years ago

People

(Reporter: Marco Bosch, Assigned: Daniel (Leaf) Nunes)

Tracking

Details

(Reporter)

Description

18 years ago
I sometimes download the latest *.xpi files from the mozilla ftp
site. However, they are not contained in the /pub/mozilla/nightly/latest dir.
I have to manually search the latest few date-time directories to find
the latest one to contain the linux-xpi directory. 
If one wanted to write some automatic download utility, this would make it
almost impossible to do so...

Comment 1

18 years ago
where do you find .xpi files on ftp.mozilla.org?
Summary: put *.xpi files in /pub/mozilla/nightly/latest → put *.xpi files in /pub/mozilla/nightly/latest
(Reporter)

Comment 2

18 years ago
The latest one at the moment can be found at
pub/mozilla/nightly/2000-12-08-08-Mtrunk/linux-xpi

Comment 3

18 years ago
not installer but build.
This bug is now both for Mac, Linux and Win32
Assignee: ssu → cls
Status: UNCONFIRMED → NEW
Component: Installer → Build Config
Ever confirmed: true
OS: Linux → All
QA Contact: gemal → granrose
Hardware: PC → All
Actually, this is not build config either.  Nor is it the browser product.  Over
to the mozilla.org product
Assignee: cls → rko
Component: Build Config → Server Operations
Product: Browser → mozilla.org
QA Contact: granrose → endico

Comment 5

18 years ago
Throwing to leaf in hope of finding better owner than me.
Assignee: rko → leaf

Comment 6

18 years ago
we don't put xpi files in latest because there is absolutely no reason for them
to be there.  The stub installers need a url to download them from which is the
dated dir.  The blob installers include the xpi files inside them.  You should
not be downloading xpi files standalone.  There is no guarantee that they will
work with previous versions of the stub installers.  You should be downloading
the stub installer or the blob installer.

wontfix.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.