Streaming LoD Terrain SpiderGL demo display is blue

RESOLVED INVALID

Status

()

Core
Canvas: WebGL
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
In 4.0b9, whatever the renderer (OpenGL or Angle), Streaming LoD Terrain SpiderGL demo display is blue.
If the renderer is OpenGL and the shader validator is set to false, the terrain is greenish on the left side and redish on the right side.
The following errors show up in the shader error log, visible immediately below the demo:

[SHADER LOG]
FAIL:
ERROR: 0:30: 'texture2D' : no matching overloaded function found 
ERROR: 0:30: 'x' :  field selection requires structure, vector, or matrix on left hand side
Note that this demo I believe does a texture fetch in the vertex shader; this is an optional feature of GL, and there is a get parameter that tells you how many vertex texture fetches are allowed.  It's entirely possible that it's 0 on intel hardware, both with desktop GL and with ANGLE.
This seems to work now, with the latest ANGLE.  Reopen if not the case, please!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
How can it work (blank frame) with:
WebGL Renderer: (WebGL unavailable)
although I have directX runtime installed.
May be bug 630019 or a consequence of bug 625118.

If I set webgl.force-enabled to true:
* WebGL RendererIntel -- Mobile Intel(R) 4 Series Express Chipset Family -- 2.1.0 - Build 8.15.10.2226
* I don't use ANGLE even if OpenGL is not recommended for Intel's GPUs.
* The terrain is greenish on the left side and redish on the right side.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ANGLE is broken in today's (and the last two days') nightly builds; you'd have to try one from about 3 days ago, or tomorrow's.
(Reporter)

Comment 6

7 years ago
With today's build:
WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
comment 0 and comment 1 are still applicable: it is blue and there is a fail in shader log.
Whoops, I spoke too soon; I was testing the wrong build which was using desktop GL.

However -- this is still not a bug.  The streaming LOD demo uses a vertex texture fetch, which is an optional feature that ANGLE doesn't support (or more accurately, ANGLE allows 0 vertex shader texture fetches).  At some point it might be extended to allow it, but it doesn't; so this reporting blue (and the shader failing to compile) is a valid result here.  So, this is (unfortunately) INVALID, because the bug lies in the source demo depending on an optional feature (and not checking for it, etc).

The angle issue for vertex texture fetch is http://code.google.com/p/angleproject/issues/detail?id=95 -- there's a preliminary patch there as well.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.