[Extension] Slow bookmarking with 1.6.1 enabled

VERIFIED FIXED

Status

Cloud Services
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: tracy, Assigned: rnewman)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
As reported in the forum bookmarking via the star UI is slow with 1.6.1 enabled.  Confirmed on Mac 3.6.13 with 1.6.1 and same on XP

STR:
1) Have Fx sync 1.6.1 enabled (it doesn't even have to be connected)
2) Open any page that is not bookmarked already (if it is remove it)
3) Click the white star in the awesomebar

Tested results:
The star flashes to colored, immediately goes white for 3-5 second then changes to colored, finally make the page bookmarked.  While the star UI is white, there is no response from it.

expected results:
The Star UI doesn't flash and go white, but simply updates to colored immediately, indicating the page is bookmarked.

This is a regression from 1.5.1, it works fine there.  It does not occur on trunk or beta.
(Assignee)

Comment 1

7 years ago
Tracy, how many bookmarks did you test with? (And what folder hierarchy?) Interested to see if this is a volume-related issue.
(Reporter)

Comment 2

7 years ago
I am not sure how many I have 400-500, it is my robust everyday use profile. But I can confirm not seeing it with a fresh/default profile.

I keep most bookmarks in the unsorted folder plus a few dozen in folders on the toolbar and oh and a bunch more have collected in folders in the bookmarks menu. That last set mostly from imports or syncing up with various locales
So this only occurs on Firefox 3.5/3.6, not with Minefield?
(Reporter)

Comment 4

7 years ago
I didn't try to 1.6.1 install on minefield.
(In reply to comment #4)
> I didn't try to 1.6.1 install on minefield.

Please don't. It's not meant to be installed there. My question was: does this problem only occur on Firefox 3.5/3.6 + Sync 1.6.1 whereas 3.5/3.6 + 1.5.x as well as Minefield with built-in Sync are fine?
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> My question was: does this
> problem only occur on Firefox 3.5/3.6 + Sync 1.6.1 whereas 3.5/3.6 + 1.5.x as
> well as Minefield with built-in Sync are fine?

That is correct.
(Assignee)

Comment 7

7 years ago
I'm going to try to repro this.
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
(Assignee)

Comment 8

7 years ago
With a clean profile, there's an instantaneous flicker of the star when you click it. Brief, but it's there.

By adding progressively more bookmarks to Unsorted Bookmarks, up to 155 items, I was able to gradually increase the duration of the flicker.

My guess, without yet diving deeply, is that recomputing the children anno when you add a bookmark takes longer and longer as the number of children increases. On 3.x it appears that doing so is a blocking operation for the browser; the flicker is presumably because the callback has not returned yet.
(Assignee)

Comment 9

7 years ago
Pretty sure that's it. Philipp is about to land a change that eliminates the children annotation, which might solve this problem. Will check as soon as that happens.
(Assignee)

Updated

7 years ago
Depends on: 623418
(Assignee)

Comment 10

7 years ago
Tracy, could you verify whether this still occurs in 1.6.2?
(Assignee)

Comment 11

7 years ago
User reported that this is fixed in 1.6.2.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

7 years ago
veridied with 1.6.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.