Discovery pane details page navigation

VERIFIED FIXED in 5.12.9

Status

P3
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: fligtar, Assigned: cvan)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
We didn't put any navigation on the discovery pane details page assuming the back button and clicking on "Get Add-ons" again would return to the disco pane. Neither of those is true.

We need a way to get from the details page back to the main page. Assigning to chowse for updated design.
Note that making the back button work is basically a part of bug 591905 but it is looking like an extremely difficult fix. Making clicking on get add-ons go back to the main page would be very simple if we want to do that
Created attachment 503981 [details]
Mock-up: Backlink on Detail Page

Added a backlink to the top-right corner.

@WebDev: That is a floating link, and the title should flow around it with a 2em left- and 1em bottom-margin. The triangle is U+25B4, with a slight baseline shift to keep it centered.
Duplicate of this bug: 627992
Thanks Chowse.  -> cvan for implementation.
Assignee: chowse → cwiemeersch
Target Milestone: 5.12.7 → 5.12.8
Target Milestone: 5.12.8 → 5.12.9
(Assignee)

Comment 5

8 years ago
Committed: https://github.com/jbalogh/zamboni/commit/f479359
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Using history does not work.

1. Click on Get Add-ons.
2. Go to a detail page.
3. Click on Extensions (part of the AOM).
4. Go back to Get Add-ons, click Back to Add-ons.
5. Find yourself outside the disco pane on Extensions again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
If I'm reading this right the code here uses history.go(-1) to go back. That was never going to work properly until bug 602256 was fixed. That is all the global back buttons in the AOM uses. Even now it is fixed it will not just navigate the disco pane back to the previous URL in that frame, it will navigate the entire AOM back to what it last displayed.

It might work out ok though once bug 591905 and bug 628290 are fixed.
I told him to use JS to go back because we don't have a way of knowing where you came from (same with the forward button).  How should we implement it if not like that?  Is there a possibility of not needing the navigation at all and landing the real fix in the browser?
(Reporter)

Comment 9

8 years ago
What page would you come from if not the main pane? Also, it says "Back to Add-ons" which is sorta a specific page maybe. I am fine with making the link always go to the pane.
(In reply to comment #9)
> What page would you come from if not the main pane? Also, it says "Back to
> Add-ons" which is sorta a specific page maybe. I am fine with making the link
> always go to the pane.

Where does the forward button go?
(In reply to comment #8)
> I told him to use JS to go back because we don't have a way of knowing where
> you came from (same with the forward button).  How should we implement it if
> not like that?  

Why don't we store the :version/:os part of the base URL in localstorage and figure out the full URL from there?
(In reply to comment #8)
> I told him to use JS to go back because we don't have a way of knowing where
> you came from (same with the forward button).  How should we implement it if
> not like that?  Is there a possibility of not needing the navigation at all and
> landing the real fix in the browser?

Once bug 591905 this will probably become unnecessary in that the back/forward buttons should work properly. I'm going to get a final patch up for that and it will probably land today or over the weekend.
(Assignee)

Comment 13

8 years ago
Committed: https://github.com/jbalogh/zamboni/commit/7274a82
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Comment 11 / comment 13 work for me, using Firefox 3.6+, from https://addons.allizom.org/en-US/firefox/discovery/pane/4.0/Darwin, clicking through to the various add-ons, then clicking "Back to Add-ons", I'm taken to https://addons.allizom.org/en-US/firefox/discovery/pane/4.0/Darwin, etc.

Verified FIXED.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.