Netscape 0.6 aborts using Macromedia Flash plug-in.

VERIFIED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
P3
normal
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: Allan Jacobs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Version Information
===================
Mozilla/5.0 (X11; U; SunOS 5.8 sun4u; en-US; m18) Gecko/20001207
SunOS algol 5.8 Generic_108528-03 sun4u sparc SUNW,Ultra-2

Steps to reproduce the crash
============================
(1)  Get copies of Macromedia Flash Player 4 for Solaris.
     Navigate to http://www.macromedia.com/shockwave/download/.
     Click on "Macromedia Flash Player" under "Download Macromedia
     Flash Player".  Click on "Download Now".  Save ShockwaveFlash.class
     and libflashplayer.so to disk.  Exit Netscape.
(2)  Become root.
(3)  Copy libflashplayer.so and ShockwaveFlash.class into the
     plugins directory of your Netscape build.
(4)  Become a normal user.  Start up Netscape.
(5)  Navigate to about:plugins
(6)  Verify that "Shockwave Flash 4.0 r12" is installed as a plug-in.
(7)  Navigate to http://www.macromedia.com/shockwave/download/
     Click on "Macromedia Flash Player" under "Download Macromedia
     Flash Player".
(8)  Click on the text "Test Players".  NS6 will abort.

(9)  Bring up NS6 again.
(10) Navigate to http://computing.netscape.com/computing/main.tmpl
(11) Click on "Downloads".
(12) In the page that comes up, under "Departments", click on "Browser Plug-ins".
(13) Click on "Plug-ins"==>Plug-ins
     The URL of this page is
      http://home.netscape.com/plugins/index.html#search?cp=pi1
(14) Click on "Download Now" under "RealPlayer by RealNetworks".
(15) Click on the text "Test Players".  NS6 will abort.

Command Line Output
===================

algol% ./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.:/export/home/netscape,v0.6/dist/lib:
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=


Gdk-WARNING **: shmat failed!

Gdk-WARNING **: shmat failed!
Registering plugin 0 for: "*","All types",".*"
Registering plugin 0 for: "application/x-java-vm","Java(tm) Plug-in",""
Registering plugin 1 for: "application/x-java-applet","Java(tm) Plug-in",""
Registering plugin 2 for: "application/x-java-applet;version=1.1","Java(tm)
Plug-in",""
Registering plugin 3 for: "application/x-java-applet;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 4 for: "application/x-java-applet;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 5 for: "application/x-java-applet;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 6 for: "application/x-java-applet;version=1.2","Java(tm)
Plug-in",""
Registering plugin 7 for: "application/x-java-applet;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 8 for: "application/x-java-applet;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 9 for: "application/x-java-applet;version=1.3","Java(tm)
Plug-in",""
Registering plugin 10 for:
"application/x-java-applet;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Registering plugin 11 for: "application/x-java-bean","Java(tm) Plug-in",""
Registering plugin 12 for: "application/x-java-bean;version=1.1","Java(tm)
Plug-in",""
Registering plugin 13 for: "application/x-java-bean;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 14 for: "application/x-java-bean;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 15 for: "application/x-java-bean;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 16 for: "application/x-java-bean;version=1.2","Java(tm)
Plug-in",""
Registering plugin 17 for: "application/x-java-bean;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 18 for: "application/x-java-bean;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 19 for: "application/x-java-bean;version=1.3","Java(tm)
Plug-in",""
Registering plugin 20 for:
"application/x-java-bean;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Registering plugin 0 for: "application/x-shockwave-flash","Shockwave Flash","swf"
Registering plugin 1 for: "application/futuresplash","FutureSplash Player","spl"
in SetSecurityButton
Document http://sunweb.central/ loaded successfully
Document http://www.macromedia.com/shockwave/download/ loaded successfully
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  72 (X_PutImage)
  Serial number of failed request:  61
  Current serial number in output stream:  71

algol% ./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.:/export/home/netscape,v0.6/dist/lib:
     LIBRARY_PATH=.:./components
.... (same as above) ....
Document http://home.netscape.com/plugins/index.html?cp=dowdep4 loaded successfully
Document http://home.netscape.com/plugins/audio-video.html loaded successfully
in SetSecurityButton
@

Gdk-WARNING **: shmat failed!

Gdk-WARNING **: shmat failed!
Registering plugin 0 for: "*","All types",".*"
Registering plugin 0 for: "application/x-java-vm","Java(tm) Plug-in",""
Registering plugin 1 for: "application/x-java-applet","Java(tm) Plug-in",""
Registering plugin 2 for: "application/x-java-applet;version=1.1","Java(tm)
Plug-in",""
Registering plugin 3 for: "application/x-java-applet;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 4 for: "application/x-java-applet;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 5 for: "application/x-java-applet;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 6 for: "application/x-java-applet;version=1.2","Java(tm)
Plug-in",""
Registering plugin 7 for: "application/x-java-applet;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 8 for: "application/x-java-applet;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 9 for: "application/x-java-applet;version=1.3","Java(tm)
Plug-in",""
Registering plugin 10 for:
"application/x-java-applet;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Registering plugin 11 for: "application/x-java-bean","Java(tm) Plug-in",""
Registering plugin 12 for: "application/x-java-bean;version=1.1","Java(tm)
Plug-in",""
Registering plugin 13 for: "application/x-java-bean;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 14 for: "application/x-java-bean;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 15 for: "application/x-java-bean;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 16 for: "application/x-java-bean;version=1.2","Java(tm)
Plug-in",""
Registering plugin 17 for: "application/x-java-bean;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 18 for: "application/x-java-bean;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 19 for: "application/x-java-bean;version=1.3","Java(tm)
Plug-in",""
Registering plugin 20 for:
"application/x-java-bean;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Registering plugin 0 for: "application/x-shockwave-flash","Shockwave Flash","swf"
Registering plugin 1 for: "application/futuresplash","FutureSplash Player","spl"
in SetSecurityButton
Document http://sunweb.central/ loaded successfully
Document http://www.macromedia.com/shockwave/download/ loaded successfully
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  72 (X_PutImage)
  Serial number of failed request:  61
  Current serial number in output stream:  71

algol% ./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.:/export/home/netscape,v0.6/dist/lib:
     LIBRARY_PATH=.:./components
.... (same as above) ....
Document http://home.netscape.com/plugins/index.html?cp=dowdep4 loaded successfully
Document http://home.netscape.com/plugins/audio-video.html loaded successfully
in SetSecurityButton
@Document http://sunweb.central/ loaded successfully
Document http://www.macromedia.com/shockwave/download/ loaded successfully
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  72 (X_PutImage)
  Serial number of failed request:  61
  Current serial number in output stream:  71

algol% ./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.:/export/home/netscape,v0.6/dist/lib:
     LIBRARY_PATH=.:./components
.... (same as above) ....
Document http://home.netscape.com/plugins/index.html?cp=dowdep4 loaded successfully
Document http://home.netscape.com/plugins/audio-video.html loaded successfully
in SetSecurityButton
Error loading URL
http://cgi.netscape.com/cgi-bin/pi_log.cgi?fromURL=audio-video.html&toURL=http://home.netscape.com/plugins/get_real.ht
ml: 804b0002
Document
http://ureg.netscape.com/iiop/UReg2/reg/register?U2_ENDURL=http://home.netscape.com/plugins/get_real.html&U2_EXITURL=http://hom
e.netscape.com/plugins/get_real.html&U2_FAILURL=http://home.netscape.com/plugins/get_real.html&U2_SOURCE=plugins
loaded successfully
Document
http://ureg.netscape.com/iiop/UReg2/login/login?U2_ENDURL=http://home.netscape.com/plugins/get_real.html&U2_NEW_ENDURL=http://h
ome.netscape.com/plugins/get_real.html&U2_SOURCE=plugins&U2_EXITURL=http://home.netscape.com/plugins/get_real.html&U2_FAILURL=http://hom
e.netscape.com/plugins/get_real.html&U2_CS=ISO_8859-1:1987&U2_LA=en loaded
successfully
we don't handle eBorderStyle_close yet... please fix me
we don't handle eBorderStyle_close yet... please fix me
Document http://ureg.netscape.com/iiop/UReg2/login/loginform loaded successfully
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  72 (X_PutImage)
  Serial number of failed request:  51
  Current serial number in output stream:  61

Comment 1

18 years ago
Reporter: have you tried this with one of the latest nightlies? If so does the
same thing happen?

Comment 2

18 years ago
Marking WORKSFORME due to lack of response. Reopen if this is still occuring in
the latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Keywords: flash

Comment 3

8 years ago
fwiw, we'd need a stack trace from running w/ --sync in order to determine the initial blame.

https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

I'm going to assume that this was a problem with Flash and was fixed in a later version of flash. There's no real way to tell, but it's slightly better to have fewer useless bugs in Core:Plug-ins.

Oh, if you have problems w/ a current version of Firefox + Flash, please file a new bug :)
Assignee: serhunt → nobody
Status: RESOLVED → VERIFIED
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-flash
Version: Trunk → 4.x

Comment 4

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 4.x → unspecified
You need to log in before you can comment on or make changes to this bug.