FIPS breaks sync key validation and server sync

RESOLVED DUPLICATE of bug 443386

Status

Cloud Services
Firefox Sync: Crypto
--
major
RESOLVED DUPLICATE of bug 443386
7 years ago
7 years ago

People

(Reporter: Christopher Barth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.16) Gecko/20101130 Firefox/3.5.16 Glue/4.5 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Tested on 1.5.1. and 1.6.1

Enabling FIPS will cause sync to return Sync key errors and "Error while syncing"

Reproducible: Always

Steps to Reproduce:
1. Enable FIPS
2. Attempt to Sync
3.
Actual Results:  
"Error while syncing"

Expected Results:  
Should be able to use sync key from FIPS store not just PSM.

0x80004005 (NS_ERROR_FAILURE)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443386
You need to log in before you can comment on or make changes to this bug.