Autoconfiguration does not change user name for SMTP when changed and re-tested

RESOLVED DUPLICATE of bug 540205

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 540205
8 years ago
7 years ago

People

(Reporter: Tim Orbaker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

I have accounts on a virtual SMTP server that uses the entire email address as the login. Account setup for SMTP does not work.



Reproducible: Always

Steps to Reproduce:
1 - Start create account.
2 - Enter name, email and password
3 - Auto configuration runs and claims success, even though it uses the 'name' and not 'name@domain.tld' email for login (meaning that it's not actually attempting to log in).
4 - Change the name to the full email address
5 - Create the account
6 - Check the SMTP user name. It is 'name' and not 'name@domain.tld'

Actual Results:  
The SMTP login is set to 'name' (as originally tried) and not 'name@domain.tld' (as corrected)

Expected Results:  
The SMTP login should be changed from 'name' to 'name@domain.tld' in this case. I suspect that this bug occur, no matter what the change in the login was.

Also: While it claims that the account is configured, and it will work until you try to send email, it appears that the account setup is not trying to log in since it claims that using 'tim' as the login name checks out. But the following session with my server makes me disbelieve that:

* OK Dovecot DA ready.
A LOGIN tim (redacted)
A NO Authentication failed.
B LOGIN tim@orbaker.com (redacted)
B OK Logged in.
C LOGOUT
* BYE Logging out
C OK Logout completed.
That looks like an Imap log not an smtp one.

so the domain you are having issues with is orbaker.com right ?
Whiteboard: dupme
(Reporter)

Comment 2

7 years ago
The domain is correct. If you contact me directly, I will set up a mailbox that you can use for testing.
This is very similar to bug 634604. Reproducible with 3.1.11. Remote server is Dovecot 1.0.7+SSL.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 540205
You need to log in before you can comment on or make changes to this bug.