Contextual commands (such as Unable to delete/create bookmark) with right click does not work after a Customize

VERIFIED FIXED in Firefox 55

Status

()

defect
P3
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: benoit.grange, Assigned: mak, Mentored)

Tracking

Trunk
Firefox 55
x86
All
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox27 affected, firefox28 affected, firefox29 affected, firefox30 affected, firefox38 affected, firefox38.0.5 affected, firefox39 affected, firefox40 affected, firefox41 affected, firefox-esr24 affected, firefox-esr31 affected, firefox-esr38 affected, blocking2.0 .x+, firefox55 verified, firefox56 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9 ID:20110110191547

While doing Litmus tests on sync I found that I was unable to delete bookmarks.



Reproducible: Couldn't Reproduce

Steps to Reproduce:
I tried to reproduce, but to no avail

1. Add new bookmark
2. Sync
3. Unable to delete bookmark
Actual Results:  
Nothing happens when right click on the bookmark item from the bookmark menu and do delete.

Expected Results:  
Bookmark is deleted.

I think "tracy" is also trying to reproduce.
Bookmark can be deleted when doing "show all bookmarks".

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

8 years ago
It is reproducible for me and always... Delete/Properties actions from
bookmark action menu are not working.

My build ID is: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110116
Firefox/4.0b10pre

and if I:
Open Bookmark Dialog
Move with mouse over existing item
Open Item dialog with RightMouseButton
Choose Delete or Properties Action

... and nothing happens...

Comment 2

8 years ago
Well, there is one prerequisite to "broke" the behavior:
You must do some menu customization before.
For me the way how to reproduce it is:

- restart browser and all Bookmark operations work as expected
- RightMouseButton click to menu, choose Customize and do something (for me drag&drop Home button from right to left for example)
- then the Bookmark context menu operations like Delete/Properties are not working anymore
(Reporter)

Comment 3

8 years ago
Well done,  you do not even need to customise anything, just open the customise dialog and click on Done !

FF4nightly (US locale) has the problem
FF4beta9 (french locale) has the problem
FF4beta9 (french locale) has the problem
FF4beta7 (french locale) has the problem
FF4beta6 -- ftp site says forbidden !
FF4beta5 (french locale) has the problem
... and I am tired

FF3.6.13 (french locale) is ok

How can we bring this to QA, this is not a huge problem, but not very nice to users !

Comment 4

8 years ago
Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110116 Firefox/4.0b10pre

Steps to reproduce:
1. Add a bookmark.
2. Go to View > Toolbars > Customize...
3. Add a new button and click on Done
4. Open Bookmarks Menu and right click on the bookmark.
5. Select Delete from the context menu.

I was able to reproduce with the steps above, due to that I will mark this bug as new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 560198
Keywords: regression
Summary: Unable to delete bookmark with right click (sync related ?) → Unable to delete bookmark with right click after a Customize

Comment 5

8 years ago
Confirmed with str of comment #4 on 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre ID:20110117030328

Regression window:
Works;
http://hg.mozilla.org/mozilla-central/rev/00955067e4b5
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100504 Minefield/3.7a5pre ID:20100505053644
Fails:
http://hg.mozilla.org/mozilla-central/rev/d7393e28fb2d
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100504 Minefield/3.7a5pre ID:20100505071655
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=00955067e4b5&tochange=d7393e28fb2d
thanks, marking as regression of bug 528884
Blocks: 528884
(Reporter)

Comment 7

8 years ago
FYI the bug is still there in 4.0b10
(Reporter)

Comment 8

8 years ago
FYI the bug is still there in 4.0b11
(Reporter)

Comment 9

8 years ago
FYI the bug is still there in 4.0b12

Comment 10

8 years ago
This should be blocked, because of the main feature is broken.
blocking2.0: --- → ?
Summary: Unable to delete bookmark with right click after a Customize → Unable to delete/create bookmark with right click after a Customize

Updated

8 years ago
Duplicate of this bug: 637223

Updated

8 years ago
OS: Windows XP → All
The main feature is broken only after users customize their toolbars - I don't think this should block, but before I mark it: Marco, do you see that regression causing other problems?
blocking2.0: ? → .x+
sorry, missed the comment :(
sounds like customize doesn't correctly restart the toolbar object, so most likely this is limited to managing bookmarks in the toolbar, should not cause any other bad behavior.
Whiteboard: [places-next-wanted]

Comment 14

8 years ago
(In reply to comment #13)
> sorry, missed the comment :(
> sounds like customize doesn't correctly restart the toolbar object, so most
> likely this is limited to managing bookmarks in the toolbar, should not cause
> any other bad behavior.
Not Bookmarks toolbar,
This happens Bookmarks in Menubar and Chevron inBookmarks Toolbar.
sorry, misread the report, conclusions won't change, btw.

Updated

8 years ago
Duplicate of this bug: 644888

Updated

8 years ago
Summary: Unable to delete/create bookmark with right click after a Customize → Contextual commands (such as Unable to delete/create bookmark) with right click does not work after a Customize
Additional info: at point of clicking done after adding button, the following (possibly related?) appears in the error console

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/search/search.xml ::  :: line 91"  data: no]

Workaround: clicking the 'X' to exit the customize dialog (instead of clicking 'done') appears to prevent the bug's occurrence (the uncaught exception error does still occur).
The recent fix of bug 606884 may have changed something here, could anybody check reproduceability in current Nightly please?

Comment 19

8 years ago
I can still reproduce on
http://hg.mozilla.org/mozilla-central/rev/060127d32405
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110614 Firefox/7.0a1 ID:20110614031407

Steps to reproduce:
1. Start Nightly with New Profile
2. Open Bookmarks Menu (Alt + B)
3. Go to View > Toolbars > Customize...
4. Add a new button and click on Done
5. Open Bookmarks Menu(Alt + B) and right click on the bookmark.
6. Select Properties from the context menu.

Actual Result:
At step6, nothing happen

Expected  Result:
Properties dialog should appears

Updated

8 years ago
Duplicate of this bug: 688723

Updated

7 years ago
Duplicate of this bug: 716290
No longer blocks: 560198

Updated

7 years ago
Duplicate of this bug: 778735
So is the reproduce-able for all FF users? Or just some undefined subset that I happen to fall into?
Duplicate of this bug: 812878
Still an issue on Nightly 20.0a1 (2012-11-20) on Win 7 x64.

Comment 26

5 years ago
This should be fixed ASAP.

Because, In Australis, There is a customized mode in the place that is easy to stand out more, and this problem must increase in the user.
Still an issue on nightly 30.0a1 (2014-02-05), win 7 x64 using the STR in comment 19.
The right click context menu of a bookmark in the Bookmark Menu (ALT+B) is all grayed out.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Whiteboard: [places-next-wanted]
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: p=0

Comment 28

5 years ago
Firefox 29 users are surfacing this issue on SuMo, perhaps because they are using Customize more often than average to rearrange their toolbars.

https://support.mozilla.org/questions/997136
https://support.mozilla.org/questions/997268

Is there any known workaround other than:

(1) Exit and restart Firefox
(2) Use the Bookmarks Sidebar or Library dialog

Updated

5 years ago
Duplicate of this bug: 1003571

Comment 30

5 years ago
Will there be an attempt to fix this bug? Evidently it's been around for years. It is easily recreated and I find it quite annoying. Thanks.
(In reply to Peter Myers from comment #30)
> Will there be an attempt to fix this bug? Evidently it's been around for
> years. It is easily recreated and I find it quite annoying. Thanks.

this bug only affects the menubar afaik, the new bookmarks panel should be working as expected.

Comment 32

5 years ago
I have no idea what a "menubar afaik" is, but I can tell you the new bookmarks panel does NOT work as expected when you follow the instructions in issue #1003571 (that issue was considered a duplicate of this issue).
(In reply to Peter Myers from comment #32)
> I have no idea what a "menubar afaik" is, but I can tell you the new
> bookmarks panel does NOT work as expected when you follow the instructions
> in issue #1003571 (that issue was considered a duplicate of this issue).

This contradicts what you wrote in Bug 1003571 Comment 0:
> ...
> 2. Enable Menu Bar (make Menu Bar visible).
> ...
> 8. Select Bookmarks on the Menu Bar.

The "new bookmarks panel" is invoked by the icon next to the Star Button, FYI.

Comment 34

5 years ago
It seems you do not understand the problem. There is never a problem selecting the bookmarks panel on the menu bar. Please read the balance of the complaint in issue #1003571. I will reproduce it here:

"9. Right click on the bookmark created in step 3.


Actual results:

Delete and other choices cannot be selected because they are grayed out.


Expected results:

You should be able to select Delete and other choices and they should not be grayed out."

Stated another way, after following the instructions in issue 1003571, you are not able to right click on any item in the bookmarks panel without all choices grayed out, meaning they cannot be selected.

Comment 35

5 years ago
(In reply to Peter Myers from comment #34)
> It seems you do not understand the problem. There is never a problem
> selecting the bookmarks panel on the menu bar.

Peter,

I think what Marco meant by his comment was: the context menu items are grayed out and inaccessible on the Bookmarks menu on the classic Menu Bar, but not on the drop-down Bookmarks menu displayed when you click the new bookmark list icon on the main toolbar.

This is no consolation to users who prefer the Menu Bar, but does provide another (perhaps more easily accessible) workaround for those who have not removed the new icons from their Navigation Toolbar.
Comment hidden (spam)

Comment 37

5 years ago
Thanks you for your response. I am aware of the workaround and that the new Bookmarks Icon does not suffer this problem. When I migrated to 29.0 I noticed the problem I reported. Evidently it's been an issue for years. I am just a "lowly" user of software, but it seems to me, in this case, it would be prudent to do some of the following: 1) fix the problem; 2) remove the drop-down Bookmarks Menu from the Classic Menu Bar; 3) document the issue. etc. Perhaps there are other solutions. Surely I am not the only one of millions of FF users who has/will encounter this problem. I would think the developers would want to clean it up not only to maintain a world class browser but not to have to deal with people like me who raise the question.
Fyi, I still see the bug as described in comment #2, from four years ago.

1) Start FF, click Bookmarks, drop down and right click an item, and receive a valid context menu.
2) CLick the customize menu button, click "customize", click "exit customize"
3) Repeat step 1) and all items in the context menu are grayed out until you restart FF

Comment 39

4 years ago
Currently running Firefox 38.0.5 and this issue is still there.

Steps to reproduce:
- start the layout customizer
- exit the layout customizer
- open the bookmark menu on the menu bar
- right-click on a bookmark or bookmark folder
- the context menu that appears has all options grayed out.

Expected: A working context menu in the bookmark menu.

Workaround 1: use the bookmark organizer (or whatever it's called in the English version of Firefox) and edit bookmarks there, the context menu in the bookmark organizer is not grayed out.
Workaround 2: restart Firefox. But the problem immediately returns when using the customizer again.

This bug was reported over 4 years a go, why hasn't it been fixed?
Flags: needinfo?(mak77)
(In reply to bart from comment #39)
> This bug was reported over 4 years a go, why hasn't it been fixed?

Cause there are thousands bugs, many have higher priorities, while the Firefox desktop team is only made up by a few developers.
We don't have the resources to fix everything.

If anyone has javascript debugging skills and some time to dedicate to this, that'd help. The fix is likely between browser-places.js and browserPlacesViews.js. Likely customize breaks the views subtly so that on customization end we need to recreate/restart something.
Assignee: mak77 → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(mak77)
Mentor: mak77
Whiteboard: p=0 → p=0 [diamond][lang=js]

Comment 41

4 years ago
Ah right, didn't think of that...

You mentioned the need to restart something 4 years a go (2011-03-15):
"sorry, missed the comment :(
sounds like customize doesn't correctly restart the toolbar object, so most likely this is limited to managing bookmarks in the toolbar, should not cause any other bad behavior."

.... the context menu of the bookmarks on the toolbar works fine here, the context menu is not grayed out, I'm having this problem in the bookmark-menu.
could be in the meanwhile the toolbar has been fixed, I know for sure there have been changes when new customization was implemented.
Priority: -- → P3

Comment 43

3 years ago
All options in the right-click menu greyed out. Didn't use Customize button at all.
If I press Ctrl+N to open a new window the right click in this new window works as expected.

Xubuntu 14.04, Firefox 49.0.2
I tried to reproduce this bug in Nightly 55.0a1 (2017-06-08) and notice that the context items "Cut" and "Delete" are not available (i.e. greyed out) for the bookmarks in the "Recently Bookmarked" section. However, these items are available (and work) on the bookmarks at their actual location (e.g. in "Other Bookmarks", which is the default Folder for bookmarks in a fresh profile). I could not reproduce customizing to affect this.

As far as I can see, this phenomenon is not the bug reported here, so I suggest marking this bug as fixed.

Marco, what is your opinion on this?
Flags: needinfo?(mak77)
(In reply to Claas Augner [:claas] from comment #44)
> I tried to reproduce this bug in Nightly 55.0a1 (2017-06-08) and notice that
> the context items "Cut" and "Delete" are not available (i.e. greyed out) for
> the bookmarks in the "Recently Bookmarked" section. However, these items are
> available (and work) on the bookmarks at their actual location (e.g. in
> "Other Bookmarks",

The bug is reproducible (at least on Windows 10) with the following steps:
1. open customization
2. close customization
3. open the bookmarks menu from the MAIN window menubar (not the nav-toolbar widget, not the bookmarks toolbar)
4. right click on a bookmark, any
5. all the options are greyed out

By looking into it again, I indeed see that the issue can only be with the "legacy" menubar, it's the only view that we don't restart on customizeEnd.
Flags: needinfo?(mak77)
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Whiteboard: p=0 [diamond][lang=js] → [fxsearch]

Comment 47

2 years ago
mozreview-review
Comment on attachment 8876118 [details]
Bug 625778 - Contextual commands on the main menubar bookmarks menu don't work after a customization.

https://reviewboard.mozilla.org/r/147548/#review152094

LGTM
Attachment #8876118 - Flags: review?(adw) → review+

Comment 48

2 years ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/cad0db00e0b4
Contextual commands on the main menubar bookmarks menu don't work after a customization. r=adw
https://hg.mozilla.org/mozilla-central/rev/cad0db00e0b4
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Flags: qe-verify+
I managed to reproduce the issue described in Comment 45 on Firefox 55.0a1 (2017-03-17), under Windows 10x64.
The issue is no longer reproducible on Firefox 55.0b3, or on Firefox 56.0a1 (2017-06-21).
Tests were performed under Windows 10x64 and under Ubuntu 16.04x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.