bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Missing decoding caractors in some frame

VERIFIED WORKSFORME

Status

()

Core
Internationalization
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Hashimoto, Takehiro, Assigned: Shanjian Li)

Tracking

({intl})

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
##On Mizilla 0.6 



When I accessed the page using frame.

The page(over field) use 4 flames written in Japanese.

On one frame, decode was missing, each time.

Other flames are showed correctly.





I checked that page with Mozilla/4.08(PPC,Nav) shows

correctly.I can send screen shots to compare.



Thanks for reading my bad English.



Regards,

Hiro

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

18 years ago
Reassign to shanjian.
Looks like auto detection does not recognize that frame (as EUC-JP).
Assignee: nhotta → shanjian

Updated

18 years ago
Keywords: intl

Comment 2

18 years ago
Changed QA contact to andreasb@netscape.com for now.
QA Contact: teruko → andreasb

Comment 3

18 years ago
The top page which introduces the frames has no
meta charset tag. Having auto-detection for
Japanese doesn't help much in initially deciding what
the encoding is. 

Is auto-detection designed to apply to each frame separately
currently? We need to make sure that it really applies to
each frame separately. Otherwise, the results would depend
so much on what the prior "current" encoding is.

Comment 4

18 years ago
Changing QA contact to ylong@netscape.com for now.
QA Contact: andreasb → ylong
(Assignee)

Comment 5

18 years ago
I tried this with the latest build and could not see any problem. One of the frame
is euc-jp, and that frame is displayed fine. That means we did applied autodetection
to each frame individually.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
Shanjian: I tried it on 05-11 trunk build on all 3 platforms, seems Auto-detect 
doesn't detect this page well(onr of frame display garbled) with All, Asian and 
Japanese.  I have to specified it as EUC-JP.

Comment 7

17 years ago
There are 2 child frames, one is with x-jis meta-tag and another is EUC-JP 
without meta-tag.  Base on this, it works fine on 05-17 Mac trunk build. 
Mark it as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.