[Web Console] Allow users to open the web console in a new Window

RESOLVED DUPLICATE of bug 577721

Status

()

Firefox
Developer Tools
--
enhancement
RESOLVED DUPLICATE of bug 577721
7 years ago
7 years ago

People

(Reporter: Jeremie, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
At the moment, when a user select the "Web Console" in the Tools menu, the console is open on top of the current tab. 

Sometimes it could be uncomfortable to have the tab height reduce due to this tool.

Is it possible to have the opportunity to detach the console from the tab and put it in its own window (something similar to Firebug that can be open both on the current tab or in its own window) ?

Comment 1

7 years ago
This is definitely a desired feature and one that is on our radar. Offhand, I don't know of another bug open on this.

This won't be in Firefox 4, but you can bet we plan to head in this direction.
(Reporter)

Comment 2

7 years ago
Thanks, this is a great news.

BTW I have to said that in a UI point of view, It could be better to have the Web Console opening at the bottom rather than on top of tab.

The reading habits for most of the people are from top to bottom therefor, putting something on top of a UI give it some strength and add a strong visual noise to the users. IMO, information available in the Web Console are aside information about what's happen in the tab so it could be much more comfortable to have the Web console at bottom in a "secondary" reading position.

Once again, it's the design choice made by the Firebug team and I can see that I'm much more often working with the Firebug console open at the bottom than with the Web Console open on top (but it's just my own habits so it needs to be checked on a larger panel).

Comment 3

7 years ago
(In reply to comment #2)
> Thanks, this is a great news.
> 
> BTW I have to said that in a UI point of view, It could be better to have the
> Web Console opening at the bottom rather than on top of tab.

This bug - or another - should also cover the use case of pinning the console to the bottom of the browser. By no means were we trying to restrict the UI in this way.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577721
You need to log in before you can comment on or make changes to this bug.