App tab is on top of normal tabs

RESOLVED DUPLICATE of bug 601228

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 601228
8 years ago
8 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 503938 [details]
Screenshot

I think this is a regression recently, but I'm not sure, and I'm not sure exactly how to reproduce it other than to restore my current session: but with my current session, I have a window which when it restores on startup, the normal tabs underlay the app tab. Attaching screenshot.

As soon as resize the window to cause the overflow arrows to appear/disappear the problem goes away.
(Reporter)

Comment 1

8 years ago
Nominating because of a reproducible-for-me bug in a significant new UI feature of Firefox 4.
blocking2.0: --- → ?
Whiteboard: regression?
Does it always happen when you restore a session, or only your specific session?
(Reporter)

Comment 3

8 years ago
Not any session, no. And there are other windows in this session which restore correctly.
<sigh> Looks like this has reared its head again. 

STR: on windows 7
1. Start Minefield with new profile
2. Open a 2nd browser window.
3. Pin an AppTab and a regular tab in 2nd window.
4. Firefox > Exit, Choose "Save and Quit" on Quit Minefield dialog.
5. Start Browser again

In the 2nd window the app tab overlaps the normal tab. Note even if you have app tabs in the 1st window they never seem to overlap, only additional windows.

This is basically the same as bug 601228 but that was resolved worksforme, apparently by bug 582950, but without really ever understanding what the root cause was. Looks like whatever causes it has reappeared at some point.

Do we need another more recent regression range or will the one in bug 582950 comment 15 do?
Version: unspecified → Trunk
> Do we need another more recent regression range or will the one in bug 582950
> comment 15 do?

Sorry I meant bug 601228 comment 15

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601228
blocking2.0: ? → ---
Whiteboard: regression?
You need to log in before you can comment on or make changes to this bug.