l10n weirdness with a null row in the default locale

VERIFIED FIXED in 5.12.6.*

Status

VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: jbalogh, Assigned: potch)

Tracking

5.12.6.*

Details

(Reporter)

Description

8 years ago
1. addon.default_locale = en-us
2. version.release_notes has two translation rows: de: '', en-us: NULL
3. Try to edit release_notes in en-us, observe:

- The text is gray and italic like when you have an en-us translation and switch to another locale
- Saving makes the textbox disappear, nothing gets saved
- Trying to switch to a different locale says you have unsaved changes, even if nothing was entered

Updated

8 years ago
Duplicate of this bug: 626589
(Reporter)

Updated

8 years ago
Duplicate of this bug: 627515
(Assignee)

Comment 3

8 years ago
http://github.com/jbalogh/zamboni/commit/b6b4bac
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 4

8 years ago
verified fixed  @ https://addons.allizom.org/z/en-US/developers/addon/home-links/profile

Moving this to 5.12.6.* since we have had multiple reports about this issue.
Status: RESOLVED → VERIFIED
Target Milestone: 5.12.7 → 5.12.6.*
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.