Enhancement - Enable a Right-Click "Close Tab" Option in "List All Tabs"

RESOLVED DUPLICATE of bug 618791

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 618791
8 years ago
8 years ago

People

(Reporter: cab26715, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre

*** ENHANCEMENT ***

I thought of a simple to code, new feature that can be added to the "List All Tabs" button to the left of the window controls.

Add an option to delete a tab by right-clicking the tab in the "List All Tabs" list.  Should be simple to add, since the code is already there when clicking on the "X"s by the menu bar.

All you need to do is create an array matching each tab open to each item listed in the "List All Tabs" menu.  Then, if you right-click the second tab (assuming you start counting at zero) in the "List All Tabs" list, you just call the function CLOSE_TAB(tab_array[number]), where "number" would be "1" referring to the second tab.

Reproducible: Always

Steps to Reproduce:
N / A
Actual Results:  
N / A
(Reporter)

Comment 1

8 years ago
This would be useful when LOTS of tabs are open.

Another option for implementing this is by listing all tabs in "List All Tabs" but including a small "X" close button to the right of each item, like so:

Microsoft             [X]
IBM                   [X]
CISCO                 [X]

This option in comment 1 would be quicker to close a tab than right-clicking and selecting "Close Tab".
(Reporter)

Comment 2

8 years ago
I think of new things all the time that could be useful and added to Firefox, I should be a programmer working for you!
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618791
You need to log in before you can comment on or make changes to this bug.