Panorama: display of the lower part of character like g, j or p (in the title tab) is cut

VERIFIED FIXED in Firefox 4.0b12

Status

Firefox Graveyard
Panorama
P3
trivial
VERIFIED FIXED
7 years ago
a year ago

People

(Reporter: Loic, Assigned: raymondlee)

Tracking

unspecified
Firefox 4.0b12
x86
Windows Vista

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Latin characters with downstroke like g, j or p included a title tab are bad displayed in Panorama, in fact the lower part is missing.

Maybe the field displaying the title tab in Panorama should be larger.

Reproducible: Always




Screenshot of tabs displayed in Panorama: 
http://img3.imageshack.us/img3/6610/coupem.png
(Reporter)

Comment 1

7 years ago
I should add I'm using the latest FF4b9 in French.
Duplicate of this bug: 626271
I can confirm with the latest trunk on windows 7 with an en/us build.

STR:
1. Open minefield with a new profile.
2. Open www.google.com
3. open video.google.com
4. Open panorama

Notice how the tails of g in google titles are cut off. 

This doesn't appear to be a regression, it is present right back in mid august when panorama first appeared in m/c trunk.


Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110116 Firefox/4.0b10pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
In userChrome.css the following lines solve the problem:

.tab-title {
   line-height: 20px !important;  /*add 4px to show descenders */
   bottom: -24px !important; /* + 4px for increased line-height*/
}

If someone could change the tabview.css:

http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/tabview/tabview.css
136 .tab-title {
137   bottom: -20px;
138   text-align: center;
139   width: 94.5%;
140   white-space: nowrap;
141   overflow: hidden;
142   text-shadow: 0 1px rgba(255, 255, 255, 0.6);
143 }
Blocks: 627096
bug 567029 has just landed, which may fix this issue. Can you recheck once the nightly comes out?
Priority: -- → P3
No change, this bug is still alive.
Created attachment 507413 [details]
testcase with current CSS values

But I think this is just an error in the CSS:

font-size is defined as 13px, line-height is 16px. You know the total font-height is more than font-size because of internal leading in text-shadow.

I have used the current values in the testcase: everything on the red background is cut off.
sry: I meant „internal leading and text shadow“

It seems that just 2px are cut off.

So adding line-height: 18px; to http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/tabview/tabview.css#136 would fix this.
(Assignee)

Comment 9

7 years ago
Created attachment 510239 [details] [diff] [review]
v1

Sent it to try
http://tbpl.mozilla.org/?tree=MozillaTry&rev=7daeb50026a2

Builds and logs will be available at http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/raymond@raysquare.com-7daeb50026a2.
Attachment #510239 - Flags: review?(ian)
(Assignee)

Comment 10

7 years ago
Just checked.  Tab title is displayed fine for characters e.g. g, j and p on Windows XP, Mac, and Ubuntu.
(Assignee)

Comment 11

7 years ago
(In reply to comment #10)
> Just checked.  Tab title is displayed fine for characters e.g. g, j and p on
> Windows XP, Mac, and Ubuntu.

Of course, with the patch!
Comment on attachment 510239 [details] [diff] [review]
v1

thanks for fixing this!
Attachment #510239 - Flags: review?(ian) → review+
(Assignee)

Updated

7 years ago
Attachment #510239 - Flags: approval2.0?
(Assignee)

Updated

7 years ago
Assignee: nobody → raymond
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 632509
(Assignee)

Comment 14

7 years ago
Tested the builds on Mac, Windows XP and Ubuntu, all work fine.
Why are you hard-coding line-heights at all, e.g. on <body>?
(Assignee)

Comment 16

7 years ago
(In reply to comment #15)
> Why are you hard-coding line-heights at all, e.g. on <body>?

Not sure why we have that in the .body but it fixes the problem after removing it.
Comment on attachment 510239 [details] [diff] [review]
v1

OK, so please do that instead.
Attachment #510239 - Flags: approval2.0? → review-
(Assignee)

Comment 18

7 years ago
Created attachment 510975 [details] [diff] [review]
v2
Attachment #510975 - Flags: review?(ian)
(Assignee)

Updated

7 years ago
Attachment #510239 - Attachment is obsolete: true
.titlebar also looks suspicious. I suppose removing line-height from body makes it unnecessary there as well?
(Assignee)

Comment 20

7 years ago
Created attachment 511084 [details] [diff] [review]
v2

Sent to try http://tbpl.mozilla.org/?tree=MozillaTry&rev=9ace1463b70e

Waiting for the builds to complete and test them.
Attachment #510975 - Attachment is obsolete: true
Attachment #511084 - Flags: review?(ian)
Attachment #510975 - Flags: review?(ian)
Attachment #511084 - Flags: review?(ian) → review+
(Assignee)

Comment 21

7 years ago
(In reply to comment #20)
> Created attachment 511084 [details] [diff] [review]
> v2
> 
> Sent to try http://tbpl.mozilla.org/?tree=MozillaTry&rev=9ace1463b70e
> 
> Waiting for the builds to complete and test them.

Tested on Mac, Win XP and Ubuntu.
(Assignee)

Updated

7 years ago
Attachment #511084 - Flags: approval2.0?
(Assignee)

Updated

7 years ago
OS: Windows Vista → All
Note to approvers: minor CSS patch, tests passed, virtually no risk.
OS: All → Windows Vista
Comment on attachment 511084 [details] [diff] [review]
v2

low footprint, passed try, nice polish win -> a+.
Attachment #511084 - Flags: approval2.0? → approval2.0+
Created attachment 511784 [details] [diff] [review]
Patch for checkin
Attachment #511084 - Attachment is obsolete: true
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/43a8f82dfb3d
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12

Comment 26

6 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110215 Firefox/4.0b12pre

Verified issue and it's no longer reproducible.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.