If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XIF: (feature) I18N support needs to be implemented

VERIFIED INVALID

Status

()

Core
Editor
P3
normal
VERIFIED INVALID
19 years ago
16 years ago

People

(Reporter: sujay, Assigned: Akkana Peck)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
using 5/11 build of apprunner.

The following functionality needs to be implemented for editor

LANG attribute support
Arrow key to Next/Prev Unicode Code point
(Reporter)

Comment 1

19 years ago
also:

stream text using alternate charset
pasteboard unicode encoding
pasteboard local system code page
(Reporter)

Comment 2

19 years ago
also:

stream text using source document charset
implement WP-like typing rules
(Reporter)

Comment 3

19 years ago
ignore my last comment, those are already implemented in prior milestones.

Updated

19 years ago
Target Milestone: M7

Comment 4

19 years ago
Accepting bug, changing milestone to M7

Updated

19 years ago
Assignee: kostello → akkana
Target Milestone: M7 → M8

Comment 5

19 years ago
changing ownership to akkana, setting milestone to M8
(Assignee)

Updated

19 years ago
Summary: (feature) I18N support needs to be implemented → XIF: (feature) I18N support needs to be implemented
(Assignee)

Comment 6

19 years ago
Somehow the status on all of these got set back to New; re-accepting them.
(Assignee)

Comment 7

19 years ago
Move XIF/I18n bugs to M9; they're dependant on stubs which I18n is trying to get
in for M8.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 8

19 years ago
"Stream text using alternate charset" is, I think, bug 7849 (the encoding menu)
and nobody knows who's going to do this yet (it's not on our editor schedule).

As for the rest, I don't know what they mean and nobody else I've asked seems to
know either.  They all seem unrelated and probably don't belong in one bug
anyway since it's impossible to keep track of so many unrelated issues in one
bug.  Maybe kostello understood this, but no one else seems to.

I'm closing this one as invalid; if there are specific issues we need to be
handling, please open bugs on those and explain how to reproduce the feature or
lack thereof, i.e. what do you type or select, and what should the editor be
doing vs. what it's actually doing.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
Verified Invalid
You need to log in before you can comment on or make changes to this bug.