Closed Bug 626046 Opened 11 years ago Closed 11 years ago

Crash [@ operator new(unsigned int) | js::InitJIT(js::TraceMonitor*) ]

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 624645
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, Whiteboard: softblocker)

Crash Data

It is a residual crash signature in the trunk but there was a small spike in crashes from 4.0b9pre/20101226.
It is #31 top crasher in 4.0b10pre for the last week.

Signature	operator new(unsigned int) | js::InitJIT(js::TraceMonitor*)
UUID	2ec1955b-341d-4500-aa67-0ede32110114
Time 	2011-01-14 09:41:30.687251
Uptime	2120
Last Crash	2124 seconds (35.4 minutes) before submission
Install Age	8357 seconds (2.3 hours) since version was first installed.
Product	Firefox
Version	4.0b10pre
Build ID	20110114030359
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 6
Crash Reason	Unhandled C++ Exception
Crash Address	0x7c81eb33
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0863

Frame 	Module 	Signature [Expand] 	Source
0 	kernel32.dll 	RaiseException 	
1 	mozcrt19.dll 	_CxxThrowException 	throw.cpp:159
2 	mozcrt19.dll 	operator new 	obj-firefox/memory/jemalloc/crtsrc/new.cpp:57
3 	mozjs.dll 	js::InitJIT 	js/src/jstracer.cpp:7644
4 	mozjs.dll 	JSCompartment::init 	js/src/jscompartment.cpp:112
5 	mozjs.dll 	js::gc::NewCompartment 	js/src/jsgc.cpp:2867
6 	mozjs.dll 	JS_NewCompartmentAndGlobalObject 	js/src/jsapi.cpp:2954
7 	xul.dll 	CreateNewCompartment 	js/src/xpconnect/src/nsXPConnect.cpp:965
8 	xul.dll 	xpc_CreateGlobalObject 	js/src/xpconnect/src/nsXPConnect.cpp:1003
9 	xul.dll 	xpc_CreateSandboxObject 	js/src/xpconnect/src/xpccomponents.cpp:3234
10 	xul.dll 	nsXPCComponents_utils_Sandbox::CallOrConstruct 	js/src/xpconnect/src/xpccomponents.cpp:3430
11 	xul.dll 	nsXPCComponents_utils_Sandbox::Call 	js/src/xpconnect/src/xpccomponents.cpp:3321

The regression range could be on Christmas day:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0ab0603bea99&tochange=f5eb60e1bc6e

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=operator%20new%28unsigned%20int%29%20|%20js%3A%3AInitJIT%28js%3A%3ATraceMonitor*%29
blocking2.0: --- → ?
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624645
blocking2.0: ? → betaN+
Whiteboard: softblocker
Crash Signature: [@ operator new(unsigned int) | js::InitJIT(js::TraceMonitor*) ]
You need to log in before you can comment on or make changes to this bug.