If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thumbnails should be ordered vertically if the group is higher than wide / Thumbnails should be as large as possible

RESOLVED DUPLICATE of bug 595224

Status

Firefox Graveyard
Panorama
P4
normal
RESOLVED DUPLICATE of bug 595224
7 years ago
2 years ago

People

(Reporter: Andreas Jung, Unassigned)

Tracking

Trunk
Future
x86
Windows XP

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre

At the moment TabCandy always tries to order tab thumbnails horizontally.
But if the group that contains the tabs is higher than wide it would be advantageous to order the tabs vertically, because they would be displayed bigger then and therefore easier to recognize.

Reproducible: Always

Steps to Reproduce:
1. Create a new tab group
2. Resize the tab group so that its (much) higher than wide
3. Open a few tabs in the group

Actual Results:  
TabCandy orders the thumbnails horizontally and wastes space / leaves space unused.

┌--------------┐
|┌-----┐┌-----┐|
||  1  ||  2  ||
||     ||     ||
|└-----┘└-----┘|
|┌-----┐       |
||  3  |       |
||     |       |
|└-----┘       |
|              |
|              |
|              |
|              |
|              |
|              |
|              |
└--------------┘


Expected Results:  
TabCandy should display the thumbnails as big as possible / order them vertically in this case.


┌--------------┐
|┌-------┐     |
||       |     |
||   1   |     |
||       |     |
|└-------┘     |
|┌-------┐     |
||       |     |
||   2   |     |
||       |     |
|└-------┘     |
|┌-------┐     |
||       |     |
||   3   |     |
||       |     |
|└-------┘     |
└--------------┘

Updated

7 years ago
Version: unspecified → Trunk

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Target Milestone: --- → Future
This is a dupe of bug 595224, which is a wontfix. :( We tried some patches out as experiments (available on that bug, though they won't apply cleanly any more), but we felt the dynamic resizing of whitespace that would be required to keep this up was a little odd. I made a comment on that bug, though, which when I read now is not a full sentence:

> That says, if someone has a brilliant patch which does this in a smoother,
nicer fashion.

Clearly I meant, if that's the case, we would consider it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595224
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.