harfbuzz incorrectly built not thread safe

RESOLVED DUPLICATE of bug 585425

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 585425
7 years ago
7 years ago

People

(Reporter: Jeremy Huddleston, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I noticed a bunch of these while building firefox 4.0b9:

hb-private.h:216:2: warning: #warning "Could not find any system to define platform macros, library will NOT be thread-safe"


The problem seems to be that the thread-safe code is within a HAVE_GLIB ifdef, but HAVE_GLIB is never defined (despite it being on my system, it is not in mozilla-config.h)

configure.in has this:
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 1.3.7 gobject-2.0)

$ /opt/local/bin/pkg-config --modversion gobject-2.0
2.26.1

$ /opt/local/bin/pkg-config --modversion glib-2.0
2.26.1

but it seems that the HAVE_GLIB is never getting #defined anywhere because there is no AC_DEFINE(HAVE_GLIB)

In fact, the only occurrence of HAVE_GLIB seems to be in harfbuzz:

$ ack HAVE_GLIB
gfx/harfbuzz/src/hb-private.h
195:#ifdef HAVE_GLIB

gfx/harfbuzz/src/main.cc
32:#ifdef HAVE_GLIB
52:#ifdef HAVE_GLIB

gfx/harfbuzz/src/test.c
34:#ifdef HAVE_GLIB
61:#ifdef HAVE_GLIB
(Reporter)

Updated

7 years ago
Summary: harfbuzz incorrectly built not thread safe when → harfbuzz incorrectly built not thread safe
This is not (currently) a problem; we don't use harfbuzz from multiple threads. If/when we do, we'll need to implement the necessary thread-related functionality for all platforms, . (Also, see bug 585425 and bug 585431.)
(Reporter)

Comment 2

7 years ago
Ok, while not specifically a problem yet, it seems that we should still have HAVE_GLIB properly set (AC_DEFINE()), if it's available.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 585425
You need to log in before you can comment on or make changes to this bug.