Closed Bug 626164 Opened 11 years ago Closed 8 years ago

clobberer gets confused when there are multiple entries in the builds table only distinguishable by builddir

Categories

(Release Engineering :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: philor, Unassigned)

References

Details

(Whiteboard: [clobberer])

https://build.mozilla.org/clobberer/index.php?master=http%253A%252F%252Fproduction-master03.build.mozilla.org%253A8010%252F&slave=moz2-linux64-slave08&builddir=tm-lnx64-dbg&branch=tracemonkey&buildername=Linux+x86-64+tracemonkey+leak+test+build says

... tracemonkey-linux64-debug:1295135899:philringnalda@gmail.com ...

which is nice and all, but as http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295142562.1295142927.26433.gz&fulltext=1 (which should have picked up that clobber) says,

/builds/slave/tracemonkey-linux64-debug doesn't exist, skipping

because it only has a /builds/slave/tm-lnx64-dbg.
...and clobberer never issues clobber requests for the short names...

Seeing the same on the SeaMonkey buildbot/clobberer system.
Assignee: nobody → bhearsum
So...the way clobberer works, there's a 1-1 mapping of "Pretty name", which is displayed in the UI, and "ID", which is stored in the "name" part of each checkbox. So when we build the page, we're ending up with the IDs that are associated with the old, longly named, build directories. Simple fix is to wipe the clobberer DB of these, or completely.

Going to look for a permanent fix before going that route.
(In reply to comment #2)
> So...the way clobberer works, there's a 1-1 mapping of "Pretty name", which is
> displayed in the UI, and "ID", which is stored in the "name" part of each
> checkbox. So when we build the page, we're ending up with the IDs that are
> associated with the old, longly named, build directories. Simple fix is to wipe
> the clobberer DB of these, or completely.
> 
> Going to look for a permanent fix before going that route.

The permanent fix is not obvious, so I cleaned out the entire DB. There's a backup, in case we need it.
Summary: Clobberer still broken post-shortnames for TraceMonkey (at least) → clobberer gets confused when there are multiple entries in the builds table only distinguishable by builddir
Lowering severity, returning to the pool.
Assignee: bhearsum → nobody
Severity: blocker → normal
I'd like to see this become part of a larger clobberer rewrite.
Priority: -- → P3
Whiteboard: [clobberer]
Turns out release clobberer is still broken even after the purge.
Assignee: nobody → bhearsum
After some investigation, I think the release clobberer issues are different than this bug, so I filed bug 628671 on it.
Assignee: bhearsum → nobody
Duplicate of this bug: 660472
Product: mozilla.org → Release Engineering
John, something to keep in mind and/or resolve when your clobberer rewrite is done?
Flags: needinfo?(jhopkins)
Yes - in the rewrite, I'm planning to have buildername be the primary key so duplicate builders will be impossible.
Flags: needinfo?(jhopkins)
Component: Other → Tools
QA Contact: hwine
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Component: Tools → General
You need to log in before you can comment on or make changes to this bug.