flash ends up in lower quality sometimes

RESOLVED FIXED in mozilla2.0b10

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: vlad, Assigned: roc)

Tracking

({regression})

unspecified
mozilla2.0b10
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

I've noticed this on a few sites -- the rdio collections circle/bubble graph, and now the flash at http://www.logitech.com/en-us/speakers-audio -- the text is not antialiased, though it looks like it tried to do AA but was instead forced to 100% opacity somehow.  Could be flash thinking it has a surface with an alpha channel and us not giving it one, not sure.

Bad (Firefox 4 nightly): http://i.imgur.com/VPLCs.png
Good: http://i.imgur.com/5bHKJ.png

Comment 1

9 years ago
Regression window:
Works;
http://hg.mozilla.org/mozilla-central/rev/212a391d3b79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110052514
Fails:
http://hg.mozilla.org/mozilla-central/rev/bdbef533364f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110081923
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=212a391d3b79&tochange=bdbef533364f
Blocks: 596451
Keywords: regression

Comment 2

9 years ago
Did you try this after bug 611698 landed (past two days)?

Comment 3

9 years ago
(In reply to comment #2)
> Did you try this after bug 611698 landed (past two days)?
Yes, Latest m^c nightly.
And confirmed again on http://hg.mozilla.org/mozilla-central/rev/413eb50d4b81
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110116 Firefox/4.0b10pre ID:20110116030325
This sounds like the espn.com issue I reported in bug 611698.
For me, turning Cleartype off doesn't affect the bad rendering -- still stays bad.  Problem sounds/looks to be very similar to bug 611698, though.
Also, the espn.com poll looks fine to me here.  Marking this related to 611698, though.
Blocks: 611698
If you try with OOPP disabled and Cleartype manually disabled, do you see the same problem?

Comment 8

9 years ago
Confirmed - seeing issue mentioned in comment 0.
Although, for me, all sites mentioned in bug 611698 work fine.

Comment 9

9 years ago
Posted file reduced html
FYI
Switching tab or scrolling up/down helps for upper sample(espn.com).
To answer my own question: no, that does not trigger the problem.

Comment 11

9 years ago
(In reply to comment #7)
> If you try with OOPP disabled and Cleartype manually disabled, do you see the
> same problem?

OOPP disabled : The problem does not happen
Cleartype manually disabled : The problem happens.
I meant both at the same time.

Comment 13

9 years ago
(In reply to comment #12)
> I meant both at the same time.

Disabled both;
http://www.logitech.com/en-us/speakers-audio : The problem does not happen
espn.com: The problem does not happen, but the font is thin than that of disabled OOPP only
OK I've figured out what the problem is. The problem is that Flash recomposites its entire internal buffer over our own irrespective of what rectangle we asked it to paint. In PluginInstanceChild::PaintRectToSurface we only clear the rectangle that we're asking Flash to paint into. So Flash ends up recompositing text outside the repaint region over and over itself, which eventually saturates any pixels that were partially touched by the text.

The best way to fix this is to set the GDI clip rect to the rectangle we expect Flash to paint into.
Posted patch fixSplinter Review
This fixes it.
Assignee: nobody → roc
Attachment #504314 - Flags: review?(jmathies)
Setting the clip rect like this might speed up Flash's final BitBlt too, for some performance gain.
Whiteboard: [needs review]
Patch applied locally looks great, Rob.

Updated

9 years ago
Attachment #504314 - Flags: review?(jmathies) → review+

Updated

9 years ago
Whiteboard: [needs review]
Keywords: checkin-needed
Whiteboard: [needs landing]
blocking2.0: ? → final+
http://hg.mozilla.org/mozilla-central/rev/aa611c72c337
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
Whiteboard: [needs landing]
Target Milestone: --- → mozilla2.0b10
You need to log in before you can comment on or make changes to this bug.