Navigation buttons "Next" and "Previous" are broken in Add-ons Manager

RESOLVED DUPLICATE of bug 591905

Status

()

defect
RESOLVED DUPLICATE of bug 591905
9 years ago
9 years ago

People

(Reporter: jeanphilippe.halimi, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [hardblocker])

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

The problem occurs in the Add-ons Manager. When you're browsing in the "Get Add-ons" section, click on any extension you can see. You can see a detailed view of this extension. Now click on the "Extensions" tab (or any other side tab). If you click on the "Previous" button, it is no more possible to go to the "Get Add-ons" homepage.

What I see is, clicking on a side tab break the navigation system of the Add-ons manager.

Reproducible: Always

Steps to Reproduce:
1. Go to the Add-ons Manager
2. Click on "Get Add-ons"
3. Select any add-on you see in the homepage
4. Then, when the detailed view appears, click on any other side tab
5. Try to go back to the "Get Add-ons" homepage via "Previous" and "Next".
Actual Results:  
It seems to go back to "Get Add-ons" homepage.

Expected Results:  
To be able to go back to "Get Add-ons" homepage.

Comment 1

9 years ago
Confirmed on 
http://hg.mozilla.org/mozilla-central/rev/3d4620449437
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre ID:20110115030345
Status: UNCONFIRMED → NEW
Component: General → Add-ons Manager
Ever confirmed: true
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: unspecified → Trunk

Updated

9 years ago
blocking2.0: --- → ?
Blocking for straight-up brokenness. Given the focus and importance of the AOM, hard-blocking on it.
blocking2.0: ? → betaN+
Whiteboard: [hardblocker]
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591905
You need to log in before you can comment on or make changes to this bug.