Closed Bug 626229 Opened 9 years ago Closed 9 years ago

trunk doesn't compile with --disable-{ogg,wave,webm}

Categories

(Core :: Audio/Video, defect)

Other
Other
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla5

People

(Reporter: bartml, Assigned: cajbir)

References

Details

Attachments

(2 files)

User-Agent:       Konqueror
Build Identifier: 

Compilation of Firefox ends with the following error:

AudioParent.cpp
(...)
In file included from /home/firefox/mozhg/src/dom/ipc/AudioParent.cpp:40:
../../dist/include/mozilla/dom/AudioParent.h:44:27: error: nsAudioStream.h: No such file or directory
In file included from /home/firefox/mozhg/src/dom/ipc/AudioParent.cpp:40:
../../dist/include/mozilla/dom/AudioParent.h:80: error: 'nsAudioStream' was not declared in this scope
../../dist/include/mozilla/dom/AudioParent.h:80: error: template argument 1 is invalid
/home/firefox/mozhg/src/dom/ipc/AudioParent.cpp:50: error: expected `)' before '*' token

and many other errors in AudioParent.cpp, possibly all resulting from missing nsAudioStream.

I have --disable-ogg --disable-wave --disable-webm in my .mozconfig, so I suspect this is a reason.


Reproducible: Always
Version: unspecified → Trunk
Adding doug.turner@ and kinetik@ to CC list as they are people responsible for adding AudioParent.cpp and other audio-related pieces in patch from bug 599089.

I guess compiling with this set of options should really work as even configure in some case gives advice to set it: see http://hg.mozilla.org/mozilla-central/file/86c446a17a79/configure.in#l6197
Status: UNCONFIRMED → NEW
Ever confirmed: true
i met the same problem, unpatch the remote patch v5 will solve this problem?

since now firefox need alsa to play ogg, webm, etc, i have to disable it. i am using ossv4.
I have a patch for this. Will attach tomorrow for review.
Assignee: nobody → chris.double
Attached patch FixSplinter Review
This puts conditional compilation around the AudioStream code based on MOZ_SYDNEYAUDIO. I couldn't see how to do conditional code in .ipdl files so I stubbed out the virtual functions that are required due to the audio methods in those files being generated.
Attachment #514636 - Flags: review?(kinetik)
Attachment #514636 - Flags: review?(kinetik) → review+
Whiteboard: [needs landing post ff4]
Blocks: post2.0
No longer blocks: post2.0
Status: NEW → ASSIGNED
http://hg.mozilla.org/mozilla-central/rev/6aac39e19f60
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing post ff4]
Target Milestone: --- → mozilla2.2
Duplicate of this bug: 648000
I'm just curious.  How long will it take before this fix is in the official download:

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/latest-4.0/source/firefox-4.0.source.tar.bz2
Matt, I'll upload a rebased patch for mozilla-2.0 (Firefox 4) and request approval for landing shortly.
Chris, I have done it for you :-).
Ok, I'll leave it for you to drive it forward, thanks Bart!
Well, actually I am not sure which flags should I set for attachment and whom should I ask for approval to land this patch. Could you do it for me, please?
(Obviously I don't have write access to repo...)
Comment on attachment 524262 [details] [diff] [review]
attachment 514636 [details] [diff] [review] for mozilla-2.0 branch

Looking for approval to land this on mozilla-2.0. It allows building with all the media backends disabled (currently this gives a compile error). The patch has baked on mozilla-central for quite a while.

The patch is low risk - it only affects if the source builds or not.
Attachment #524262 - Flags: approval2.0?
Comment on attachment 524262 [details] [diff] [review]
attachment 514636 [details] [diff] [review] for mozilla-2.0 branch

not planning any more mozilla2.0 releases, but Approved for the mozilla2.0 repository, a=dveditz for release-drivers
Attachment #524262 - Flags: approval2.0? → approval2.0+
Duplicate of this bug: 875268
You need to log in before you can comment on or make changes to this bug.