Closed Bug 626296 Opened 9 years ago Closed 6 years ago

[QAC generated] troweprice.com page text super imposes midway down the page

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jgbittar, Unassigned)

References

()

Details

Steps to Reproduce
---------------------------------------
1.go to trowe.com main page
2.select Historical performancein the mutual funds section in the middle of the page
3.the results are all garble midway down the page that you can not read the text since is superimpose from the botto

What should have happened:
---------------------------------------
you should be able to read the page text



What actually happened:
----------------------------------------
you can not read any of the text since is superimposed.
Can confirm issue on Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110116 Firefox/4.0b10pre ID:20110116030325
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout
This is a site bug.  They have the table in a <div class="tableContainer"> which is styled with "height: 450px".  The table is taller than 450px, so extends outside the div, and the content after the div ends up on top of the table.

The page is in quirks mode, and IE in quirks mode treats "height" as the same as "min-height".  That's why you don't get the issue in IE.

Chrome renders the same as we do, for the same reason.

Safari doesn't show the problem, because of this wonderful bit:

  <script>
    //detect for safari change table heights
    if(BrowserDetect.browser == 'Safari' || BrowserDetect.browser == 'safari')
    {
      document.write('<style>div.tableContainer{height:auto;}');
      document.write('table>tbody{height:auto;}</style>');
    }
  </script>

Gecko 1.9.2 doesn't show the problem because the page styles the tbody as "overflow-y: scroll".  While the CSS spec says that the overflow properties have no effect on table-internal elements, old Geckos had an extension that allowed them to work on tbody (so in Firefox 3.6 you get a scrollable table body there).  We removed that extension in Gecko 2.0, both for spec compliance and because of problems it was causing.

Tim, please don't mark layout bugs "New" unless there's some good indication that they're actually our bugs.... ;)
Assignee: nobody → english-us
Component: Layout → English US
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: Trunk → unspecified
Reporter, if you're a T Rowe customer, I would suggest contacting them about the problem...
Reporter -> Are you still experiencing this issue with the latest version of Firefox 6? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
Summary: [QAC generated] page text super imposes midway down the page in the trowe website → [QAC generated] troweprice.com page text super imposes midway down the page
This seems to be fixed.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.