XPCOM Standalone build failure

VERIFIED DUPLICATE of bug 62415

Status

()

Core
XPCOM
P3
normal
VERIFIED DUPLICATE of bug 62415
18 years ago
18 years ago

People

(Reporter: Marcus Webster, Assigned: Scott Collins)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From v1.17 (and onwards) of nsLocalFileCommon.cpp attempts to build with
XPCOM_STANDALONE set fail. This is because the mEncoder and mDecoder members of
the nsFSStringConversion class have been #ifdef'd out for XPCOM standalone
builds, but code that accesses those members isn't.

Steps to reproduce
-------------------
Build from clean (on Windows) using:
nmake -f client.mak build_xpconnect

Actual Results
-------------------
Build progresses to the mozilla\xpcom\io directory, then the build stops with
the following results:

nsDirectoryService.cpp
nsLocalFileWin.cpp
nsLocalFileCommon.cpp
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(57) : error C2039: 'mEncoder'
: is not a member of 'nsFSStringConversion'
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(39) : see declaration
of 'nsFSStringConversion'
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(58) : error C2039: 'mDecoder'
: is not a member of 'nsFSStringConversion'
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(39) : see declaration
of 'nsFSStringConversion'
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(115) : error C2027: use of und
efined type 'nsIUnicodeEncoder'
M:\Private\mozilla\xpcom\io\nsFileSpec.h(214) : see declaration of 'nsIU
nicodeEncoder'
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(115) : error C2227: left of '-
>Release' must point to class/struct/union
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(116) : error C2027: use of und
efined type 'nsIUnicodeDecoder'
M:\Private\mozilla\xpcom\io\nsFileSpec.h(215) : see declaration of 'nsIU
nicodeDecoder'
M:\Private\mozilla\xpcom\io\nsLocalFileCommon.cpp(116) : error C2227: left of '-
>Release' must point to class/struct/union
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"D:\Program Files\Microsoft Visual Studio\VC98\Bin\N
MAKE.EXE"' : return code '0x2'
Stop.

Expected results
--------------------
The build process to complete successfully

Comment 1

18 years ago
Duplicate of bug 62415, which is still unconfirmed, and is probably itself a
duplicate of bug 24515, although the compile errors are not the same, and that
is the only reason bug 62415 has not been duplicated to bug 24515 yet.
Thank you,
Fabian.

*** This bug has been marked as a duplicate of 62415 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
This bug is indeed a duplicate of bug 62415 - XPCOM standalone build is broken due
to compile errors in mozilla/xpcom/io/nsLocalFileCommon.cpp.  They both deal
with mEncoder and mDecoder problems.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.