GTK error msg: Assertion 'GTK_IS_LAYOUT (layout)' failed

RESOLVED FIXED in M11

Status

Core Graveyard
Viewer App
P3
normal
RESOLVED FIXED
19 years ago
10 years ago

People

(Reporter: gerardok, Assigned: Stuart Parmenter)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Version: Seamonkey
Program: Viewer.exe
BuildID: 05-10-1999
Platform: Linux Red Hat 5.2

Opening a second window with JavaScript window.open() generates two Gtk error
messages, as follows:

Gtk-WARNING **: invalid cast from 'GtkVBox' to 'GtkLayout'

Gtk-CRITICAL **: file gtklayout.c: line 276 (gtk_layout_move): assertion
'GTK_IS_LAYOUT (layout)' failed.

Tested on Win NT and there is no failure there. It seems to happen on Linux
only.

Steps to reproduce:

1. Create a file with the following contents:

<HTML>
<HEAD>
<TITLE>test.html</TITLE>
</HEAD>
<BODY>
<SCRIPT type="text/javascript">
window.open("http://bubblegum", "ChildWindow");
</SCRIPT>
</BODY>
</HTML>

2. Load that file in viewer.exe

Actual Results: Gtk error messages displayed in console
Expected Results: No error messages.
(Reporter)

Updated

19 years ago
QA Contact: 3853 → 4015

Updated

19 years ago
Assignee: rickg → ramiro

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7

Comment 1

19 years ago
yes, its a bug.  marking assigned m7.

Updated

19 years ago
Assignee: ramiro → pavlov
Status: ASSIGNED → NEW

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
Marking M8.  If you plan to fix any of these for m7, mark them so.

Comment 3

19 years ago
this html code below doesn't pop up any kind of window or anything, so i am
having a hard time reproducing this.
(Assignee)

Updated

19 years ago
Depends on: 9185
Target Milestone: M8 → M9
(Assignee)

Comment 4

19 years ago
can't debug due to command line arguments that gtk likes causing viewer to crash
in its parsing of them.  i doubt 9185 will be fixed by M8, so i'm moving this to
m9
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 5

19 years ago
the bug i'm depending on changed to M10 so i will too.
(Assignee)

Comment 6

19 years ago
i'm crashing on bubblegum
(Reporter)

Comment 7

19 years ago
pavlov, I think it's crashing on bubblegum because an unrelated failure. You can
use a different URL in the window.open statement (i.e.
http://bubblegum/test1/hello.html)
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M12

Comment 8

19 years ago
mass-moving all m12 bugs to m13
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M13 → M11
(Assignee)

Comment 9

19 years ago
I removed gtkvboxs all together.  this is fixed.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.