All users were logged out of Bugzilla on October 13th, 2018

fake out clamdscan on staging-stage/preproduction-stage

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

During a staging release run I found that the pre_push_checks builder fails because clamdscan isn't installed. There's no real point in running a virus scan in either of these places, and they would be awfully slow. Rail suggested that we fake it out with a shell script, which seems like a good idea.
Created attachment 504465 [details] [diff] [review]
sync fake clamd

I haven't been able to test this because staging-stage isn't set-up w/ Puppet.
Attachment #504465 - Flags: review?(rail)
Comment on attachment 504465 [details] [diff] [review]
sync fake clamd

Looks fine to me.

> I haven't been able to test this because staging-stage isn't set-up w/ Puppet.

Will see it in preproduction. :)
Attachment #504465 - Flags: review?(rail) → review+
Comment on attachment 504465 [details] [diff] [review]
sync fake clamd

changeset:   263:b17d294d963a
Attachment #504465 - Flags: checked-in+
I had to land a bustage fix (s/contents/content/), because I misread the docs. preproduction-stage picked it up after that.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.