UI elements don't load fully upon opening

RESOLVED DUPLICATE of bug 603134

Status

()

defect
RESOLVED DUPLICATE of bug 603134
9 years ago
8 years ago

People

(Reporter: michalurban, Unassigned)

Tracking

({qawanted})

4.0 Branch
x86_64
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(8 attachments)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

I asked about this issue at the Fx4b9 test day and was told to file a bug. I've been experiencing this on several recent Fx4 betas on my MacBook Pro running current OS X (10.6.6 at the moment).

Various UI elements (windows, dialogs, dropdowns in web pages) often load initially as blank. It seems like the browser is frozen and nothing's happening, while in fact the page has loaded and the window needs a "nudge" (move, minimize/maximize, move other window over) to refresh display.

One example is that I'm unable to run the Grafx Bot test normally as I can't see most of the output at all. Fx 3.6 builds work fine on the same system.

Reproducible: Always

Steps to Reproduce:
I believe the same issue is manifested in several scenarios: 

1. Launch browser and wait for the window to load
2. Download a file, file save dialog opens
3. open Download Manager window
4. open a drop down list in the web page (sample URL provided)
Actual Results:  
See attached screenshots

1. Fx4-load.png - blank window appears.
2. Fx4-dialog - there is content, but Save button disabled
3. Fx4-downloads - blank DLM window loads
4. Fx4-dropdown - list opens, but can not be scrolled (it actually scrolls, but does not show it)

Expected Results:  
1. Fx4-load-moved.png - content appears after moving the window
2. Fx4-dialog-moved - after moving Save button is enabled
3. Fx4-downloads-moved - content appears after moving the window
4. Fx4-dropdown-reopened - normal behavior after reopening dropdown list

I have NVidia's CUDA drivers installed, currently version 3.2.17.
Reporter

Comment 1

9 years ago
Reporter

Comment 2

9 years ago
Reporter

Comment 3

9 years ago
Reporter

Comment 4

9 years ago
Reporter

Comment 5

9 years ago
Reporter

Comment 6

9 years ago

Comment 9

9 years ago
I experienced the same issues running Firefox 4.0b10 with a new profile on my MacBook Pro, though only when using the 9600M GT GPU; the UI rendered fine with the 9400M GPU. I also noticed that moving another window in front of the empty Firefox window would cause Firefox's UI to appear, as if being "painted in" wherever the foreground window passed over.

After systematically disabling various apps and processes, I found that turning off HoudahSpot's Tray window got rid of all the rendering bugs.
Keywords: qawanted
Version: unspecified → 4.0 Branch
Reporter

Comment 10

8 years ago
Reported issue affected Fx4 betas and was fixed in the final release. See bug 603134 for details.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603134
You need to log in before you can comment on or make changes to this bug.