Closed Bug 626409 Opened 10 years ago Closed 10 years ago

Tabs-on-Titlebar on WinXP doesn't look good on unfocused tabs.

Categories

(Firefox :: Theme, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 569850

People

(Reporter: Swapnilrustagi, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Tabs-on-Titlebar on Windows XP doesn't look good on unfocused tabs because the background color of unfocused tabs is blue(Due to Windows XP's theme). It looks nice on Windows Vista and Windows 7 but only with the default color ie. Windows Aero. It looks bad on Windows Vista and Windows 7 too when not using Windows Aero and using a different Windows Theme.

Reproducible: Always

Steps to Reproduce:
1. Launch Mozilla Firefox 4 Beta 9 on Windows XP or Windows Server 2003.
2. Open two or more tabs.
3. The unfocused tab has the issue as it is hard to read because of Windows XP themes.
Actual Results:  
The unfocused tab appears in blue which means black text on a blue background which is too awful experience. Only Windows XP x86, Windows XP 64-bit, Windows server 3003 x86 and x64 are affected.

Expected Results:  
Firefox should use it's own theme for displaying unfocused tabs like it uses for the active tab.
Dupe of bug 569850?
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Component: Toolbars → Theme
QA Contact: toolbars → theme
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 569850
(In reply to comment #4)
> 
> *** This bug has been marked as a duplicate of bug 569850 ***

Aye, it is not a complete duplicate. The other guy(reporter of bug 569850) is talking about something else, both the bugs have very little similarity which is not enough to mark them duplicate..
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #2)
> Created attachment 504483 [details]
> Firefox 4b9 with tabs in titlebar on Windows XP - default blue theme

Yeah, so isn't is awful to read the unfocused tabs. On,MS Zune Black, it's almost impossible. What I meant to say was that Firefox should also use a Google Chrome-style which means it should display all the tabs in white color regardless of the color of titlebar.
(In reply to comment #6)
> it should display all the tabs in white color
> regardless of the color of titlebar.

Bug 569850 made it so.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569850
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Swapnil, stop it.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569850
(In reply to comment #7)
> (In reply to comment #6)
> > it should display all the tabs in white color
> > regardless of the color of titlebar.
> 
> Bug 569850 made it so.
> 
> *** This bug has been marked as a duplicate of bug 569850 ***

Well, if the bug 569850 is fixed, I would like to see the changes in Firefox 4 Beta 10. If it fixes my problem then, I'm going to cancel this bug. But, however I do not feel that the issue described in that bug is relevant to mine ( Except that he is talking about titlebar and I'm too and we both have an x86 Windows XP system). Please do not again mark that as a duplicate. If Beta 10 fixes the issue, I'll cancel this myself. Ofcourse till then, any suggestions are appreiciated and welcomed.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Swapnil, you're abusing bugzilla. Again, stop it. Reopen if you see the issue in a build containing the fix for bug 569850, and only then.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569850
(In reply to comment #9)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > it should display all the tabs in white color
> > > regardless of the color of titlebar.
> > 
> > Bug 569850 made it so.
> > 
> > *** This bug has been marked as a duplicate of bug 569850 ***
> 
> Well, if the bug 569850 is fixed, I would like to see the changes in Firefox 4
> Beta 10. If it fixes my problem then, I'm going to cancel this bug. But,
> however I do not feel that the issue described in that bug is relevant to mine
> ( Except that he is talking about titlebar and I'm too and we both have an x86
> Windows XP system). Please do not again mark that as a duplicate. If Beta 10
> fixes the issue, I'll cancel this myself. Ofcourse till then, any suggestions
> are appreiciated and welcomed.

What suggestions? This issue is fixed. End of story.
(In reply to comment #11)
> (In reply to comment #9)
> > (In reply to comment #7)
> > > (In reply to comment #6)
> > > > it should display all the tabs in white color
> > > > regardless of the color of titlebar.
> > > 
> > > Bug 569850 made it so.
> > > 
> > > *** This bug has been marked as a duplicate of bug 569850 ***
> > 
> > Well, if the bug 569850 is fixed, I would like to see the changes in Firefox 4
> > Beta 10. If it fixes my problem then, I'm going to cancel this bug. But,
> > however I do not feel that the issue described in that bug is relevant to mine
> > ( Except that he is talking about titlebar and I'm too and we both have an x86
> > Windows XP system). Please do not again mark that as a duplicate. If Beta 10
> > fixes the issue, I'll cancel this myself. Ofcourse till then, any suggestions
> > are appreiciated and welcomed.
> 
> What suggestions? This issue is fixed. End of story.

I know that the bug  is solved. But, I want to wait I make sure my problem is fixed
(In reply to comment #11)
> (In reply to comment #9)
> > (In reply to comment #7)
> > > (In reply to comment #6)
> > > > it should display all the tabs in white color
> > > > regardless of the color of titlebar.
> > > 
> > > Bug 569850 made it so.
> > > 
> > > *** This bug has been marked as a duplicate of bug 569850 ***
> > 
> > Well, if the bug 569850 is fixed, I would like to see the changes in Firefox 4
> > Beta 10. If it fixes my problem then, I'm going to cancel this bug. But,
> > however I do not feel that the issue described in that bug is relevant to mine
> > ( Except that he is talking about titlebar and I'm too and we both have an x86
> > Windows XP system). Please do not again mark that as a duplicate. If Beta 10
> > fixes the issue, I'll cancel this myself. Ofcourse till then, any suggestions
> > are appreiciated and welcomed.
> 
> What suggestions? This issue is fixed. End of story.

I know that the bug  is solved. But, I want to wait I make sure my problem is fixed
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Download nightly and check, you lazy troll.
(In reply to comment #13)
> I know that the bug  is solved. But, I want to wait I make sure my problem is
> fixed

It's great that you want to make sure the issue is fixed, but this isn't your personal issue tracker. Bugzilla serves the whole Mozilla community.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569850
(In reply to comment #15)
> (In reply to comment #13)
> > I know that the bug  is solved. But, I want to wait I make sure my problem is
> > fixed
> 
> It's great that you want to make sure the issue is fixed, but this isn't your
> personal issue tracker. Bugzilla serves the whole Mozilla community.
> 
> *** This bug has been marked as a duplicate of bug 569850 ***

OK, I am totally sick of explaining this to you that the other bug is not relevant to this bug. If, you want, I quit, not from this bug but the whole Mozilla Community.
Post screenshot from nightly build, then we'll talk.
(In reply to comment #17)
> Post screenshot from nightly build, then we'll talk.

OK, I am going to. But could someone tell how to attach the screenshot???
(In reply to comment #18)
> (In reply to comment #17)
> > Post screenshot from nightly build, then we'll talk.
> 
> OK, I am going to. But could someone tell how to attach the screenshot???

https://bugzilla.mozilla.org/attachment.cgi?bugid=626409&action=enter
You need to log in before you can comment on or make changes to this bug.