Closed Bug 626411 Opened 9 years ago Closed 9 years ago

Selecting a section of URL, then clicking "Delete" stays at refresh, instead of "go"

Categories

(Core :: DOM: Editor, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b10
Tracking Status
blocking2.0 --- final+

People

(Reporter: tanner, Assigned: ehsan)

References

Details

(Keywords: regression, Whiteboard: [softblocker][fx4-fixed-bugday])

Attachments

(1 file)

If you go to the location bar, and select part of the URL, then click "Delete", instead of "Cut" or hitting backspace, the go/reload/stop button goes to reload, instead of go. This can be really annoying for people who often don't use keyboards, such as if you use the browser on a media center, or if you just browse with a mouse. 

STR:
1.) Go to location bar
2.) Highlight part of URL
3.) Right click, click delete

ER: 
Reload/Stop/Go button goes into Go state, instead of staying at refresh

AR:
Button stays in refresh state
Confirmed in Window 7 trunk. This is a regression from firefox 3.6.13
Keywords: regression
Version: unspecified → Trunk
This is most likely a dupe of bug 625452, which has been fixed on trunk.  Can you please test with the latest nightly to see if the bug happens there?
Whiteboard: [possible dupe of bug 625452]
I can still reproduce this on today's nightly.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre
Confirming.  This is a regression from bug 527935.
Whiteboard: [possible dupe of bug 625452]
And it should block.
blocking2.0: --- → ?
This is caused because the FireTrustedInputEvent is destroyed before the nsAutoPlaceHolderBatch object, which ends up calling NotifyEditorObservers.

This works correctly for Undo and Redo since the nsEditor version of these functions calls NotifyEditorObservers directly.
Whiteboard: [softblocker]
Attached patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #505271 - Flags: review?(roc)
Whiteboard: [softblocker] → [softblocker][needs landing]
Component: Location Bar → Editor
Product: Firefox → Core
QA Contact: location.bar → editor
http://hg.mozilla.org/mozilla-central/rev/26710d7a4b45
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [softblocker][needs landing] → [softblocker]
Target Milestone: --- → mozilla2.0b10
Attachment #505271 - Flags: approval1.9.2.15?
Attachment #505271 - Flags: approval1.9.1.18?
Comment on attachment 505271 [details] [diff] [review]
Patch (v1)

ditto bug 625452 comment 12 on clearing the branch approval requests
Attachment #505271 - Flags: approval1.9.2.15?
Attachment #505271 - Flags: approval1.9.1.18?
Verified on Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker] → [softblocker][fx4-fixed-bugday]
You need to log in before you can comment on or make changes to this bug.