Closed Bug 626413 Opened 9 years ago Closed 7 years ago

Update appearance of About window on Vista/7

Categories

(Firefox :: Theme, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
blocking2.0 --- -

People

(Reporter: Terepin, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: polish)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre

Check URL to see the change together with style. I don't remember if it was Faabor or Limi who agreed with me on this.

Reproducible: Always
Blocks: 579547
blocking2.0: --- → ?
Version: unspecified → Trunk
That pic with the style looks a bit better than the current style because of the color used by other windows programs matches the shade of white with light blue.
The current version looks a bit washed up and faded.
If you want to put together a patch, I'd approve it, but we won't block on this.
blocking2.0: ? → -
Now we need to find someone with free time.
Attached patch would this work?Splinter Review
This probably isn't the right way to go about doing this. Looks like aboutDialog doesn't have any native theming for any of the themes.
Comment on attachment 504544 [details] [diff] [review]
would this work?

I only briefly skimmed the patch. AFAICT that should work on systems that use Aero but won't have any effect on Windows without Aero or other platforms. I think that ideally we'd want to improve things there too.

I think it might be better make these changes for all platforms, except make the bottom box gray on non-Aero and the light blue on Aero.

If no one else has time, I can create a patch that does this later this week.
Thank you!
Can someone finish/review the patch, please?
Blocks: 639215
You have to find a reviewer and request review  for the patch
I'm presuming this is redundant now with the new about dialog?
This bug doesn't apply to Nightly and Aurora.
Apologies, I thought the release build about screens has been redesigned too; presuming not then :-)
Keywords: polish
No.
Isn't this fixed even for Stable / beta channel builds ?
Unfortunately no. No one has touched this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.