PPT file handled by mozplugger generates File not found errors

RESOLVED DUPLICATE of bug 644431

Status

()

RESOLVED DUPLICATE of bug 644431
8 years ago
7 years ago

People

(Reporter: jdm, Unassigned)

Tracking

unspecified
x86
Linux
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

(Reporter)

Description

8 years ago
On Fedora 12, when attempting to open a link that is handled by a plugin (specifically the URL via mozplugger 1.12.1 which should trigger OpenOffice.org, I believe), I consistently see this error message: "/home/t_mattjo/mozilla/firefox/kjw9ngf4.jetpack/Cache/4/42/4CA4Bd01 does not exist."
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?

Comment 1

8 years ago
Can be a symptom of bug #605101. Does the file exist? Could you list about:cache-info for the URL in question?
(Reporter)

Comment 2

8 years ago
about:cache-info doesn't exist, so I presume you mean about:cache and then the Disk cache listing.  I don't see any entry for 341-Lecture2.ppt (which is the file I was clicking from the URL that I forgot to specify).

Comment 3

8 years ago
And I assume the file doesn't exist on disk?
(Reporter)

Comment 4

8 years ago
Correct.

Comment 5

8 years ago
Any chance to try opening the link without the plugin activated/installed? (I.e. is the plugin a necessary factor?)
(Reporter)

Comment 6

8 years ago
With mozplugger disabled, the file can be opened in OpenOffice.org without any problems.

Comment 7

8 years ago
Do you have a cache-entry for the file after opening it? If there is, and you re-enable mozplugger, does it open?
(Reporter)

Comment 8

8 years ago
Hmm, still no cache-entry for the pdf after opening it.

Comment 9

8 years ago
How does it work with the plugin enabled now?
(Reporter)

Comment 10

8 years ago
Same error.
Summary: Files opened in an application generate File not found errors → PPT file handled by mozplugger generates File not found errors
I can't reproduce it with mozplugger on Fedora 14. Could you please post a log? (NSPR_LOG_MODULES=nsHttp:5,cache:5)

Comment 12

8 years ago
With risk of stating the obvious: Doesn't this sound like a mozplugger-problem? :) Should we involve Louis Bavoil and Peter Leese?
Not blocking, if more evidence appears that says it's a bad problem in our code, and it's a regression, please renominate.
blocking2.0: ? → -
I think this is a dupe of #644431. Reopen if it appears again.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644431
You need to log in before you can comment on or make changes to this bug.