Closed Bug 626475 Opened 9 years ago Closed 9 years ago

Crash in ImageLayerD3D10::RenderLayer [@ nvwgf2um.dll@0x9df92 ][@ nvwgf2um.dll@0x9de22 ][@ nvwgf2um.dll@0x15a9c3 ][@ nvwgf2um.dll@0x9bec2 ][@ nvwgf2um.dll@0x9bf22 ][@ nvwgf2um.dll@0x9de82 ][@ nvwgf2um.dll@0x9df02 ][@ nvwgf2um.dll@0xc600f ]

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 612103

People

(Reporter: bjacob, Unassigned)

References

(Blocks 1 open bug)

Details

This is our only high-volume (200/week) crash with NVIDIA 260.99 that's not already handled in an already fixed bug. If we fix it or work around it, and blacklist older NVIDIA drivers, then NVIDIA crashes should be pretty much a solved problem.


query for all crash reports with this signature:

http://crash-stats.mozilla.com/report/list?product=Firefox&branch=2.0&query_search=signature&query_type=startswith&query=nv&date=01%2F17%2F2011%2011%3A30%3A21&range_value=1&range_unit=weeks&hang_type=any&process_type=browser&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nvwgf2um.dll%400x15a9c3


sample crashes & stacks:

############################################################
############################################################

http://crash-stats.mozilla.com/report/index/1ede9800-5e60-4643-9f30-f0a772110117

0 	nvwgf2um.dll 	nvwgf2um.dll@0x15a9c3 	
1 	nvwgf2um.dll 	nvwgf2um.dll@0x155da8 	
2 	nvwgf2um.dll 	nvwgf2um.dll@0x158ba3 	
3 	nvwgf2um.dll 	nvwgf2um.dll@0x546ed 	
4 	nvwgf2um.dll 	nvwgf2um.dll@0x3b806 	
5 	d3d10_1core.dll 	CDevice::ID3D10Device1_SetShaderResources_<3> 	
6 	d3d10_1core.dll 	NMultithread::CDevice::PSSetShaderResources 	
7 	d3d10_1.dll 	D3D10Effects::CEffect::ApplyShaderBlock 	
8 	d3d10_1.dll 	D3D10Effects::CEffect::ApplyPassBlock 	
9 	d3d10_1.dll 	D3D10Effects::SRuntimePassBlock::Apply 	
10 	xul.dll 	mozilla::layers::ImageLayerD3D10::RenderLayer 	gfx/layers/d3d10/ImageLayerD3D10.cpp:209
11 	xul.dll 	mozilla::layers::ContainerLayerD3D10::RenderLayer 	gfx/layers/d3d10/ContainerLayerD3D10.cpp:263
12 	xul.dll 	mozilla::layers::ContainerLayerD3D10::RenderLayer 	gfx/layers/d3d10/ContainerLayerD3D10.cpp:263
13 	xul.dll 	mozilla::layers::LayerManagerD3D10::Render 	gfx/layers/d3d10/LayerManagerD3D10.cpp:470
14 	xul.dll 	mozilla::layers::LayerManagerD3D10::EndTransaction 	gfx/layers/d3d10/LayerManagerD3D10.cpp:244
15 	xul.dll 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:477
16 	xul.dll 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1433
17 	xul.dll 	PresShell::Paint 	layout/base/nsPresShell.cpp:6093



############################################################
############################################################

http://crash-stats.mozilla.com/report/index/3ce4744f-e7eb-4b33-b9cd-060642110117

0 	nvwgf2um.dll 	nvwgf2um.dll@0x15a9c3 	
1 	nvwgf2um.dll 	nvwgf2um.dll@0x155da8 	
2 	nvwgf2um.dll 	nvwgf2um.dll@0x158ba3 	
3 	nvwgf2um.dll 	nvwgf2um.dll@0x546ed 	
4 	nvwgf2um.dll 	nvwgf2um.dll@0x3b806 	
5 	d3d10_1core.dll 	d3d10_1core.dll@0x2a280 	
6 	d3d10_1core.dll 	d3d10_1core.dll@0x30ca5 	
7 	d3d10_1.dll 	d3d10_1.dll@0x1b927 	
8 	d3d10_1.dll 	d3d10_1.dll@0x228f3 	
9 	d3d10_1.dll 	d3d10_1.dll@0x1baa0 	
10 	dxgi.dll 	CUseCountedObject<NOutermost::CDeviceChild>::Release 	
11 	d3d10_1.dll 	d3d10_1.dll@0x19987 	
12 	xul.dll 	mozilla::layers::ImageLayerD3D10::RenderLayer 	gfx/layers/d3d10/ImageLayerD3D10.cpp:293
13 	dxgi.dll 	NOutermost::CDevice::LOLeave 	
14 	xul.dll 	mozilla::layers::ContainerLayerD3D10::RenderLayer 	gfx/layers/d3d10/ContainerLayerD3D10.cpp:288
15 	nvwgf2um.dll 	nvwgf2um.dll@0x8a602 	
16 	nvwgf2um.dll 	nvwgf2um.dll@0x18a6e6 	
17 	nvwgf2um.dll 	nvwgf2um.dll@0x5902e 	
18 	nvwgf2um.dll 	nvwgf2um.dll@0x3b9d1 	
19 	xul.dll 	mozilla::layers::ContainerLayerD3D10::RenderLayer 	gfx/layers/d3d10/ContainerLayerD3D10.cpp:288
Stack traces are similar to the ones in bug 612103.
Probably a dupe.
Note that all crashes with this signature seem to be on Geforce 400 series (very recent hardware)
Blocks: 605749
Thanks! Indeed, no build ID after January 11.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623338
Duplicate of bug: 612103
I add other top crash signatures that are not in bug 612103 summary to prevent other dupes.
Summary: Crash [@ nvwgf2um.dll@0x15a9c3 ] in ImageLayerD3D10::RenderLayer with latest NVIDIA driver 260.99 → Crash in ImageLayerD3D10::RenderLayer [@ nvwgf2um.dll@0x9df92 ][@ nvwgf2um.dll@0x9de22 ][@ nvwgf2um.dll@0x15a9c3 ][@ nvwgf2um.dll@0x9bec2 ][@ nvwgf2um.dll@0x9bf22 ][@ nvwgf2um.dll@0x9de82 ][@ nvwgf2um.dll@0x9df02 ][@ nvwgf2um.dll@0xc600f ]
You need to log in before you can comment on or make changes to this bug.