javascript.options.strict is on by default in Fx 3.6.13

RESOLVED INVALID

Status

()

Core
JavaScript Engine
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Duncan Loveday, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 2.0.50727)

I noticed recently that my 3.6.13 error console was full to the brim with warnings about undefined properties etc and wondered why as this is not the case with the Fx 4 trunk. When I go to about:config, the javascript.options.strict preference seems to be true by default. Is that by design ?

Reproducible: Always

Steps to Reproduce:
1. Load about:config in Fx 3.6.13
2. enter javascript.options.strict in the filter box
3. Note the default value of the preference
Actual Results:  
In step 3 the default value is true in Fx 3.6.13.

Expected Results:  
Unless it's intentional the default value should be false as with the Fx 4 trunk.

I don't know if this setting can effect performance - I can imagine it might because of the volume of messages being written to the console
Nope, not here.  What add-ons do you have installed?
(Reporter)

Comment 2

7 years ago
Have to check tomorrow as can't get to the PC right now.

Might have mozmill - would that do it ?
> Might have mozmill - would that do it ?

Yes.  They're changing that, but current mozmilla does in fact set strict warning on by default.
(Reporter)

Comment 4

7 years ago
That's the reason then, thanks

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.