Closed Bug 626516 Opened 10 years ago Closed 10 years ago

Scrolling about:addons is really slow on OS X

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 623615

People

(Reporter: jrmuizel, Unassigned)

Details

28.3% is in aa_render a bunch more in other CoreGraphics painting stuff.

It seems like we're probably drawing a lot more than we need to.

There's also a lot of vm churn. I'm not sure why.
I'd suggest that this should softblock because the experience is pretty bad.
blocking2.0: --- → ?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623615
We have to repaint everything when scrolling about:addons because it has rounded corners that we have to clip to, so we can't just blit stuff around.
You need to log in before you can comment on or make changes to this bug.