Segfault after starting to display a website

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: flying-sheep, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de-DE) AppleWebKit/533.3 (KHTML, like Gecko) rekonq Safari/533.3
Build Identifier: 

i’m using the newest firefox 4 beta (9) from the ubuntu ppa.

every time a webpage has almost finished loading and starts to display, firefox crashes.

this is the console output:

(firefox-4.0-bin:30971): GLib-CRITICAL **: g_hash_table_insert_internal: assertion `hash_table != NULL' failed
Attempting to load the system libmoon 
[1]    30971 segmentation fault  firefox-4.0


Reproducible: Always
We need either a crash ID from an official Mozilla.org binary build or a stack trace with debug symbols
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

8 years ago
i did it with firefox-4.0 --debug 2>&1 | tee /tmp/gdb-firefox.txt since

1. apport doesn’t catch the crash
2. in /usr/lib/firefox-4.0-4.0b9/ is no executable gdb can use with the specified command
3. /var/crash/ is empty

whole content of the file:
http://pastebin.mozilla.org/954432
http://pastebin.mozilla.org/954441
timeless, can you help with those stacktraces ?
(Reporter)

Comment 4

8 years ago
by the way: while i think i made the debug log with various addons enabled, it happens in exactly the same fraction of a second as without addons, so no addon can be the problem.
(Reporter)

Comment 5

8 years ago
seems to be fixed in hg20110202r61770.
yesterday it wasn’t

how can i see the bugs fixed with this commit?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
>how can i see the bugs fixed with this commit?

the only way would be HG bisect

marking wfm because it's unknown what this fixed
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.