some bookmarks disappear after syncing

RESOLVED DUPLICATE of bug 618403

Status

Cloud Services
Firefox Sync: Backend
--
major
RESOLVED DUPLICATE of bug 618403
7 years ago
7 years ago

People

(Reporter: Kakairo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

I have encountered this bug in both OSX and Windows 7 Starter.

Shortly after syncing with my Firefox Sync account, random bookmarks disappear.  On OSX, the bookmarks ended up in the Unsorted Bookmarks folder.  On Windows 7, the missing folders ended up in Unsorted Bookmarks, but the other bookmarks where nowhere to be seen.  Restoring from a previous bookmark backup temporarily solves the problem.

Reproducible: Always

Steps to Reproduce:
1. Enable Firefox Sync
2. Sync between two computers
3. Click on Bookmarks button or Bookmarks menu
Actual Results:  
Random bookmarks misplaced or deleted.

Expected Results:  
All bookmarks should show as normal.

I was unable to find this bug reported after searching several key terms both through Bugzilla and on Google.  Please disregard if bug has already been reported.

Comment 1

7 years ago
Please see http://philikon.wordpress.com/2010/12/28/bookmark-sync-issues/ for how to restore a backup and post a copy of your sync-log
Component: Bookmarks & History → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: bookmarks → sync-backend
Blocks: 621584
(Reporter)

Comment 2

7 years ago
I have not be able to replicate the issue since activating the sync-log.  I will continue use the sync-log, and will update if the issue appears again.
Kakairo: from your recollection, did you check for a known-missing bookmark in any folders other than Unsorted Bookmarks, or use the Search feature to look for it?

I'm interested to know if it just looked gone, but had actually ended up in a different folder, or if it really was absent.
(Reporter)

Comment 4

7 years ago
On OSX, all of the missing bookmarks (that I was aware of) appeared in Unsorted Bookmarks.

On Windows 7, some of the bookmarks showed up in Unsorted Bookmarks, but others did not.  I didn't use the Search function to look for the missing bookmarks, however I did hunt through my folders to find missing bookmarks, with no luck.
I'm going to dupe this to Bug 618403.

I suspect that bookmarks on your Windows machine were moved, not deleted, and were simply somewhere you weren't expecting.

If you have some evidence to the contrary (e.g., if you can export a snapshot from before and after the breakage -- go to Show All Bookmarks, click the Sync Bookmark star icon, and choose Export for the two dates), or can reproduce, I'd be happy to open a new issue to track that, but the reparenting to Unsorted Bookmarks looks like Bug 618403.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618403
You need to log in before you can comment on or make changes to this bug.