Tables on dashboards have different column widths

VERIFIED FIXED in 2.6

Status

support.mozilla.org
Knowledge Base Software
P4
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: erik, Assigned: erik)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

7 years ago
Each table's column 1 used to have the same width as every other table's column 1. Likewise, columns 2 were all the same width, and so on. We should get this back for visual scannability's sake.
Target Milestone: 2.4.3 → 2011Q1
(Assignee)

Updated

7 years ago
Duplicate of this bug: 627780
So here's the deal:
* Changing the table to "display: block" caused it to no longer take up 100% of the width, like so: http://grab.by/8MI9
* Changing the table to "display: table" introduces the bug in jquery ticket http://bugs.jquery.com/ticket/7960

I can't seem to find a good way to fix this otherwise. If someone wants to take another look, you're welcome to.
Adding "width: 25%" to .dashboards th {} actually cleaned up the entire table for me, though I'm not 100% sure why.
(Assignee)

Updated

7 years ago
Assignee: nobody → erik
(Assignee)

Comment 4

7 years ago
The widths don't work all the time. IHNI why. Went to pixel lengths for now. Fixed in https://github.com/jsocol/kitsune/commit/ee2d127db8f2cb1bcdeac9a85628d58121b2b07c.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: 2011Q1 → 2.6
(Assignee)

Updated

7 years ago
Duplicate of this bug: 631379
Verified columns don't move, data switches correctly with buttons
Status: RESOLVED → VERIFIED

Comment 7

7 years ago
It is not fixed for some locales. See:
https://support.allizom.org/ru/localization
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
This bug is a couple of milestones past. Please file a new one. (This also looks like a separate issue.)
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.